Bug 131917

Summary: udev (perhaps) should Provide: dev <= 3.11-1
Product: [Fedora] Fedora Reporter: Jeff Johnson <jbj>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: carenas, kajtzu
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 030-27 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-09-21 10:54:42 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jeff Johnson 2004-09-06 14:46:59 EDT
Description of problem:

Getting rid of dev package gonna need more than
%pre failure.

Here's what I see today, current fc3:

# yum -y update
Setting up Update Process
Setting up Repo:  rawhide
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
rawhide   : ################################################## 3513/3513
Excluding Packages
Excluding Incompatible Archs
Finished
Excluding Packages from Raw Hide Linux
Resolving Dependencies
 
Dependencies Resolved
                [u] dev.i386 0:3.11-1 - user
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Cannot install the dev package: mounted devfs detected.
error: %pre(dev-3.11-1) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping dev-3.11-1
Complete!

Somehow the Requires: dev needs to be satisfied. Here are
the known depending packages:

[root@wellfleet ~]# rpm -q --whatrequires dev
kdelibs-3.3.0-1
initscripts-7.77-1
which-2.16-4
mod_ssl-2.0.50-5
mkinitrd-4.1.9-1


Adding
     Provides: dev <= 3.11-1
would satisify all legacy dependencies on the dev package.

Note: That also means that udev will be erased by any
    Obsoletes: dev
that matches.
Comment 1 Harald Hoyer 2004-09-07 04:34:26 EDT
error: Failed dependencies:
        dev < 3.2-7 conflicts with kernel-2.6.5-1.358
        dev < 3.2-7 conflicts with kernel-smp-2.6.5-1.358
        dev < 3.2-7 conflicts with kernel-smp-2.6.8-1.541
        dev < 3.2-7 conflicts with kernel-2.6.8-1.541
Comment 2 Harald Hoyer 2004-09-07 04:36:31 EDT
With 
Provides: dev = 3.11-1

# rpm -Uvh dev-3.11-1.i386.rpm
error: Failed dependencies:
        udev is needed by (installed) hal-0.2.97.cvs20040901-1
Comment 3 Harald Hoyer 2004-09-07 04:39:06 EDT
and now???
Comment 4 Kaj J. Niemi 2004-09-09 08:40:51 EDT
Happens with 3.12 too.

% rpm -Fvh dev-3.12-1.i386.rpm
Preparing...               
########################################### [100%]
Cannot install the dev package: mounted devfs detected.
error: %pre(dev-3.12-1) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping dev-3.12-1
Comment 5 Arenas Belon, Carlo Marcelo 2004-09-12 16:56:03 EDT
it is not a dependency problem but a protection on the scriptlet which
is incompatible with the way udev is being deployed.

as far as /dev is mounted on a tmpfs, the dev update won't proceed and
therefore the way this update works should be reworked.

adding Obsoletes: dev and Provides: dev would be probably a way to
solve the dependency problem and get rid of the dev package all
together, as far as udev is self consistent
Comment 6 Nalin Dahyabhai 2004-09-21 10:54:42 EDT
This happens, at least as of 030-26.