Bug 1320816

Summary: osp-director: ironic-inspector service is missing from undercloud catalog - upstream backport needed
Product: Red Hat OpenStack Reporter: Gilles Dubreuil <gdubreui>
Component: instack-undercloudAssignee: James Slagle <jslagle>
Status: CLOSED ERRATA QA Contact: Raviv Bar-Tal <rbartal>
Severity: high Docs Contact:
Priority: unspecified    
Version: 8.0 (Liberty)CC: dcadzow, dmacpher, mburns, nlevinki, rhel-osp-director-maint
Target Milestone: gaKeywords: FeatureBackport
Target Release: 9.0 (Mitaka)   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: instack-undercloud-4.0.0-2.el7ost Doc Type: Bug Fix
Doc Text:
The ironic-inspector was not included in the Keystone endpoint catalog in the Undercloud. This meant you could not discover the API endpoints for ironic-inspector through the catalog. This fix adds the ironic-inspector API endpoints to the Keystone catalog. You can now discover the ironic-inspector API endpoints through the catalog.
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-11 11:29:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Gilles Dubreuil 2016-03-24 03:51:58 UTC
Openstack service 'ironic-inspector' is missing from the undercloud catalog.
The service is installed and running properly but the service and endpoints are missing.

This is a *blocker*, for instance, for fog-openstack to interface with the inspector service's API.

instack-undercloud upstream version does configure the service:
https://github.com/openstack/instack-undercloud/blob/master/elements/puppet-stack-config/puppet-stack-config.pp#L153
https://github.com/openstack/instack-undercloud/blob/master/elements/puppet-stack-config/puppet-stack-config.yaml.template#L352-L357

rpm -qa | grep tripleo
openstack-tripleo-0.0.7-1.el7ost.noarch
openstack-tripleo-heat-templates-kilo-0.8.12-2.el7ost.noarch
openstack-tripleo-common-0.3.0-3.el7ost.noarch
python-tripleoclient-0.3.1-1.el7ost.noarch
openstack-tripleo-heat-templates-0.8.12-2.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.5-1.el7ost.noarch
openstack-tripleo-image-elements-0.9.9-1.el7ost.noarch


Workaround: create introspection service and endpoints:

[stack@undercloud ~]$ openstack service create --name inspector --description "OpenStack Introspection" introspection
+-------------+----------------------------------+
| Field       | Value                            |
+-------------+----------------------------------+
| description | OpenStack Introspection          |
| enabled     | True                             |
| id          | c10122ad586b4b5c8a1a4fdd23c8285a |
| name        | inspector                        |
| type        | introspection                    |
+-------------+----------------------------------+

[stack@undercloud ~]$ openstack endpoint create --region regionOne inspector --publicurl http://192.0.2.1:5050/v1 --internalurl http://192.0.2.1:5050/v1 --adminurl http://192.0.2.1:5050/v1
+--------------+----------------------------------+
| Field        | Value                            |
+--------------+----------------------------------+
| adminurl     | http://192.0.2.1:5050/v1         |
| id           | aae25cb9f3c54c6ab76556098eb2ed43 |
| internalurl  | http://192.0.2.1:5050/v1         |
| publicurl    | http://192.0.2.1:5050/v1         |
| region       | regionOne                        |
| service_id   | c10122ad586b4b5c8a1a4fdd23c8285a |
| service_name | inspector                        |
| service_type | introspection                    |
+--------------+----------------------------------+

[stack@undercloud ~]$ openstack catalog list
+------------+---------------+-------------------------------------------------------------------------------+
| Name       | Type          | Endpoints                                                                     |
+------------+---------------+-------------------------------------------------------------------------------+
| inspector  | introspection | regionOne                                                                     |
|            |               |   publicURL: http://192.0.2.1:5050/v1                                         |
|            |               |   internalURL: http://192.0.2.1:5050/v1                                       |
|            |               |   adminURL: http://192.0.2.1:5050/v1                                          |
...(snip)...

Comment 2 Mike Burns 2016-04-07 21:36:02 UTC
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Comment 9 errata-xmlrpc 2016-08-11 11:29:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html