Bug 1321499

Summary: Failed to retrieve rpm info for selinux-policy
Product: [Fedora] Fedora Reporter: Amir <amir.imen>
Component: policycoreutilsAssignee: Vit Mojzis <vmojzis>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 23CC: dominick.grift, dwalsh, lvrabec, mgrepl, plautrba, vmojzis
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: policycoreutils-2.5-17.fc25 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-10-10 17:44:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Amir 2016-03-28 04:08:06 UTC
Description of problem:
When I press apply button in the last step of wizard for policy generator what I run by command selinux-polgengui on Fedora 23 the following error is issued. What should I do?

Version-Release number of selected component (if applicable):
Fedora 23

Failed to retrieve rpm info for selinux-policy 
Traceback (most recent call last): 
  File "/bin/selinux-polgengui", line 360, in forward 
    self.generate_policy() 
  File "/bin/selinux-polgengui", line 506, in generate_policy 
    self.info(my_policy.generate(outputdir)) 
  File "/usr/lib64/python2.7/site-packages/sepolicy/generate.py", line 1382, in generate 
    out += "%s # %s\n" % (self.write_spec(out_dir), _("Spec file")) 
  File "/usr/lib64/python2.7/site-packages/sepolicy/generate.py", line 1228, in write_spec 
    fd.write(self.generate_spec()) 
  File "/usr/lib64/python2.7/site-packages/sepolicy/generate.py", line 1190, in generate_spec


Steps to Reproduce:
1.terminal selinux-polgengui
2. choose sandbox option
3. finish the wizard and press apply

Actual results:


Expected results:
a policy

Comment 1 Vit Mojzis 2016-08-04 12:02:42 UTC
There is a patch for the issue awaiting review (selinux-policy version value returned by rpm is not properly checked before use).

Nevertheless, the failure in your case is probably caused by the fact that "selinux-policy" package is missing in your system. Please try to install it.

Comment 2 Vit Mojzis 2016-08-26 13:19:06 UTC
The issue is solved on upstream and the fix will propagate to fedora branch during next rebase.

https://github.com/SELinuxProject/selinux/commit/671f83b42ba2d18bd9b4d6995ef87d601ad3626d

Comment 3 Fedora Update System 2016-10-05 20:29:45 UTC
checkpolicy-2.5-8.fc25, libselinux-2.5-12.fc25, libsemanage-2.5-8.fc25, libsepol-2.5-10.fc25, policycoreutils-2.5-17.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b7e8e980ef

Comment 4 Fedora Update System 2016-10-06 20:59:16 UTC
checkpolicy-2.5-8.fc25, libselinux-2.5-12.fc25, libsemanage-2.5-8.fc25, libsepol-2.5-10.fc25, policycoreutils-2.5-17.fc25, secilc-2.5-6.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b7e8e980ef

Comment 5 Fedora Update System 2016-10-10 17:44:03 UTC
checkpolicy-2.5-8.fc25, libselinux-2.5-12.fc25, libsemanage-2.5-8.fc25, libsepol-2.5-10.fc25, policycoreutils-2.5-17.fc25, secilc-2.5-6.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.