Bug 1321648

Summary: Bug in /etc/profile.d/colorls.sh when using the ksh shell
Product: Red Hat Enterprise Linux 7 Reporter: Ondrej Vasik <ovasik>
Component: coreutilsAssignee: Ondrej Vasik <ovasik>
Status: CLOSED ERRATA QA Contact: Jakub Prokes <jprokes>
Severity: unspecified Docs Contact: Petr Bokoc <pbokoc>
Priority: unspecified    
Version: 7.3CC: jprokes, jscotka, pandrade, pbokoc, qe-baseos-daemons
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: coreutils-8.22-17.el7 Doc Type: Bug Fix
Doc Text:
*ksh* now correctly displays login messages When logging in to an interactive login shell, the contents of the `/etc/profile` script are executed in order to set up an initial environment. Messages which should have been displayed to the user upon logging in to the Korn shell (ksh) were suppressed due to an internal test to determine whether the shell is a login shell that relied upon the value of the `PS1` environment variable having already been set before `/etc/profile` was executed. However, this environment variable is set in the Korn shell only after `/etc/profile` is executed, which led to messages never being displayed to *ksh* users. This update provides an alternative test that does not rely on the `PS1` variable being set before `/etc/profile` execution, with the result that messages are properly displayed to users of the Korn shell upon login.
Story Points: ---
Clone Of: 1321643 Environment:
Last Closed: 2016-11-04 07:40:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1321643    

Comment 8 errata-xmlrpc 2016-11-04 07:40:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2497.html