Bug 132436

Summary: dbus init scripts do not honor stop or restart commands
Product: [Fedora] Fedora Reporter: Steve Grubb <linux_4ever>
Component: dbusAssignee: John (J5) Palmieri <johnp>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: jkeck
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-09-16 20:31:47 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 123268    

Description Steve Grubb 2004-09-13 13:48:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
dbus init scripts do not honor stop or restart commands. For example,
suppose I go into the /etc/dbus-1/system.conf file and make changes, I
want them to take effect. So, its normal to do a:

/etc/rc.d/init.d/messagebus restart

command. However this fails.

Version-Release number of selected component (if applicable):
dbus-0.22-4

How reproducible:
Always

Steps to Reproduce:
1. /etc/rc.d/init.d/messagebus restart

Actual Results:  
[root@buildhost root]# /etc/rc.d/init.d/messagebus status
dbus-daemon-1 (pid 2448) is running...
[root@buildhost root]# /etc/rc.d/init.d/messagebus restart
Stopping system message bus:                               [FAILED]
Starting system message bus: Failed to start message bus: The pid file
"/var/run/dbus/pid" exists, if the message bus is not running, remove
this file
                                                           [FAILED]
[root@buildhost root]# /etc/rc.d/init.d/messagebus stop
Stopping system message bus:                               [FAILED]
[root@buildhost root]# /etc/rc.d/init.d/messagebus status
dbus-daemon-1 (pid 2448) is running...


Expected Results:  messagebus restarted successfully.

Additional info:

Comment 1 John (J5) Palmieri 2004-09-13 15:10:52 UTC
Works for me.  Did you perhaps install dbus from source at some point
or are using a modified dbus spec?  Please attach your
/etc/dbus-1/system.conf file to this bug report.

Comment 2 Steve Grubb 2004-09-13 17:59:08 UTC
OK. I found the problem. It turns out that during the configure
script, it makes some decisions based on /etc/redhat-release being on
a system. The build system did not have that file installed (since it
wasn't required) and that's why the init scripts were not functioning
correctly.

So, the solution is to add:

BuildRequires: /etc/redhat-release

And that makes sure all decisions are correct.

Comment 3 John (J5) Palmieri 2004-09-16 20:31:47 UTC
Fixed in fc3-head

Comment 4 John (J5) Palmieri 2004-09-16 21:35:48 UTC
For some reason our build enviornments do not like redhat-release as
BuildRequires.  Adding a prebuilt init script until this is resolved.