Bug 1326709

Summary: Unable to change ovirtmgmt network to another interface
Product: [oVirt] ovirt-engine Reporter: Sahina Bose <sabose>
Component: BLL.NetworkAssignee: Dan Kenigsberg <danken>
Status: CLOSED DEFERRED QA Contact: Meni Yakove <myakove>
Severity: high Docs Contact:
Priority: medium    
Version: ---CC: bgraveno, bugs, danken, mavital, sabose, sbonazzo, stirabos
Target Milestone: ---Flags: sabose: ovirt-4.1?
sabose: planning_ack?
sabose: devel_ack?
sabose: testing_ack?
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: Known Issue
Doc Text:
When hosted-engine --deploy is run on additional hosts that have multiple FQDNs associated with it, the script will pick the host address that's returned by default. Ensure that a host's hostname resolves to the required FQDN/em1 before deploying the self-hosted engine.
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-12-05 06:08:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Network RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1277939    
Description Flags
engine.log none

Description Sahina Bose 2016-04-13 10:55:15 UTC
Created attachment 1146823 [details]

Description of problem:

During hosted-engine deployment on additional host, the following config was specified:

However, the ovirtmgmt interface was created on em2. This causes errors when HE runs on this host.

Changing the ovirtmgmt to correct interface via UI does not work either.

Logs attached

Version-Release number of selected component (if applicable):

How reproducible:
Always on one server.

Steps to Reproduce:
As in description

Additional info:

Comment 1 Sahina Bose 2016-04-13 10:56:27 UTC
Created attachment 1146824 [details]

Comment 2 Yaniv Kaul 2016-04-13 21:05:09 UTC
Meital - was this tested?

Comment 3 Simone Tiraboschi 2016-04-14 07:29:47 UTC
Sahina, can you please attach also hosted-engine-setup logs?

Comment 4 Simone Tiraboschi 2016-04-14 08:42:18 UTC
Oh, sorry, the issue is on additional host.
On the first host, hosted-engine-setup directly creates the bridge before starting the engine VM; the bridge is created via setupNetwork on the interface specified with OVEHOSTED_NETWORK/bridgeIf

On additional hosts, we simply call hosts.add so OVEHOSTED_NETWORK/bridgeIf is not relevant at all.
AFAIK host-deploy will choose the interface where the engine can reach the host based on how the host address resolves.

Comment 5 Sahina Bose 2016-04-18 09:31:41 UTC
Simone, yes. the host address that hosted-engine picked up - did resolve to em2.
The additional host had 2 FQDNs - rhsdev14.lab..com and dhcp42-219.lab..com. Host deploy used dhcp42-219.lab..com which resolves to em2.

Simone, is there a plan to allow specifying FQDN and interface for additional hosts?

Also, I was not able to use Setup networks to change ovirtmgmt to em1 interface. That should have worked, IMO.

Comment 6 Simone Tiraboschi 2016-04-18 11:21:55 UTC
(In reply to Sahina Bose from comment #5)
> Simone, is there a plan to allow specifying FQDN

Yes, we have this one:

Now we are simply calling socket.getfqdn()

>  and interface for
> additional hosts?

Nope since we can pass an interface on hosts.add
> Also, I was not able to use Setup networks to change ovirtmgmt to em1
> interface. That should have worked, IMO.


Comment 7 Sahina Bose 2016-04-21 06:46:28 UTC
Changing the title of this bug, as the initial issue is addressed by RFE

Comment 8 Dan Kenigsberg 2016-04-27 09:03:43 UTC
Sahina, I do not understand your request. ovitrmgmt is created on top of the interface that carries that IP address which the hostname resolves to.

Do you want to change that? Why?

Comment 9 Sahina Bose 2016-04-27 12:07:06 UTC
Dan, in my case the host had 2 fqdns : - rhsdev14.lab..com and dhcp42-219.lab..com

Due to some setting, hostname for host resolved to dhcp42-219.lab..com (associated with em2) 
The HE deployment picked this but I want the em1 <-> ovirtmgmt.
Using setup networks and changing ovirtmgmt to em1 did not work, as I mentioned.

If the flow for this is
1. Edit hostname and change to rhsdev14 (associated with em1) from ovirt engine
2. Re-install host
-- will this associate ovirtmgmt with em1

If it does, we can close this bug.

Comment 10 Dan Kenigsberg 2016-04-28 14:58:28 UTC
I'm afraid that there is no reasonable way to change the management address of a host after it has been added to Engine. The only solution I see is to remove the host, and add it explicitly with its requested name.

Comment 11 Sahina Bose 2016-04-29 08:08:35 UTC
Moving this from 3.6 - this looks like one of the gotchas that users need to be aware of before deploying hosted engine - ensure that hostname on host resolves to required FQDN and em1.

Comment 12 Dan Kenigsberg 2016-12-05 06:08:01 UTC
It is very annoying, but fixing this runs deep, and I do not see it happening soon.