Bug 1328068

Summary: enhance the UI messages when clicked on OK button
Product: Red Hat Enterprise Linux 7 Reporter: ptoshniw
Component: system-config-languageAssignee: Parag Nemade <pnemade>
Status: CLOSED ERRATA QA Contact: QE Internationalization Bugs <qe-i18n-bugs>
Severity: medium Docs Contact: Petr Bokoc <pbokoc>
Priority: unspecified    
Version: 7.2CC: dkochuka, eng-i18n-bugs, pbokoc, pnemade, qe-i18n-bugs, smaitra, sshedmak
Target Milestone: rcKeywords: i18n
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: system-config-language-1.4.0-7.el7 Doc Type: Enhancement
Doc Text:
Improved UI message when setting a new language in _system-config-language_ Previously, if you selected a new language to install in the *Language* graphical tool (the _system-config-language_ package), and the selected language group was not available, the error message that was displayed was not clear enough. For example, if you selected `Italian (Switzerland)`, the message displayed was: Due to comps cleanup italian-support group got removed and no longer exists. Therefore only setting the default system language With this update, the message is updated and will look similar to the following example: Due to comps cleanup, italian-support group no longer exists and its language packages will not be installed. Therefore only setting Italian as the default system language. The new message means that the new language has been enabled without having to install any new packages. After the next reboot, the system will boot in the selected language.
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-11-04 07:51:04 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
This is the message customer is facing.
none
Screenshot showing revised message, post selection of language: Italian (Switzerland), with system-config-language-1.4.0-7.el7 none

Description ptoshniw 2016-04-18 11:07:48 UTC
Created attachment 1148172 [details]
This is the message customer is facing.

Description of problem:
In system-config-language when customer launches the system-config-language utility and and selects a italian language, He is facing message as 'Due to comps cleanup italian-support group got removed and no longer exists. Therefore only setting the default system language' 

Version-Release number of selected component (if applicable):
system-config-language-1.4.0-6.el7.noarch

How reproducible:
always

Steps to Reproduce:
1.launch system-config-language
2.select italian(switzerland)

Then it prompts with the message mentioned above.

Actual results:

'Due to comps cleanup italian-support group got removed and no longer exists. Therefore only setting the default system language' 

Expected results:

'The changes will take effect after reboot' message should appear as it appears for English language

Additional info:

For other languages apart from English, the same message appears. But if we click 'Ok' on the message window and move forward the language gets successfully reflected and set after a reboot.
https://bugzilla.redhat.com/show_bug.cgi?id=920025

Comment 2 Parag Nemade 2016-04-19 03:47:15 UTC
I see from above description that only the message that is coming for non-English languages need to be changed from

'Due to comps cleanup italian-support group got removed and no longer exists. Therefore only setting the default system language' 

to

'Due to comps cleanup italian-support group got removed and no longer exists. Therefore only setting the default system language and the changes will take effect after reboot'

No other modification is required in system-config-language right?

Comment 4 Deepu K S 2016-04-19 06:04:41 UTC
(In reply to Parag Nemade from comment #2)
> I see from above description that only the message that is coming for
> non-English languages need to be changed from
> 
> 'Due to comps cleanup italian-support group got removed and no longer
> exists. Therefore only setting the default system language' 
> 
> to
> 
> 'Due to comps cleanup italian-support group got removed and no longer
> exists. Therefore only setting the default system language and the changes
> will take effect after reboot'
> 
> No other modification is required in system-config-language right?

Hello Parag,

What I feel is that we need to modify the message here, It says 
"Due to comps cleanup italian-support group got removed and no longer exists. Therefore only setting the default system language"

However, system does install the italian langpack at backend. After reboot, the Italian language is getting set.

I suggest we keep it same as RHEL 6. i.e "Resolving dependencies..." and
"The changes will take effect after reboot!"

Also, we might need to check and confirm whether this works for all non-English languages.

Thanks.

Comment 7 Parag Nemade 2016-04-19 06:49:54 UTC
Hi Deepu,
 If you check "yum groupinfo <language>-support" on RHEL6 then you can see packages that this group installs but in RHEL7 groups are removed. There is no way to find which packages to install for any language support group in RHEL7. That is why we added UI message that "language support group got removed" and packages will not be installed.

I don't think any packages will be installed when you select any non-English language from system-config-language on RHEL7. It will just set the default language and after reboot it will be effective.

As no packages found to install there will just be a flash of "Resolving dependencies..." message and it will quickly move to the next UI message "Due to comps cleanup italian-support group got removed and no longer exists. Therefore only setting the default system language".

Users might get confused what is happening as they want to see packages installed and language set to selected language that is the reason we added that above message to show groups are removed now.

Comment 12 Parag Nemade 2016-04-22 16:13:18 UTC
Fixed now in system-config-language-1.4.0-7.el7 build.

Comment 13 Jens Petersen 2016-06-30 09:09:45 UTC
Will you file an errata?

Comment 15 sandeep shedmake 2016-07-08 06:25:09 UTC
Created attachment 1177524 [details]
Screenshot showing revised message, post selection of language: Italian (Switzerland), with system-config-language-1.4.0-7.el7

# rpm -q system-config-language
system-config-language-1.4.0-7.el7.noarch

Comment 18 Parag Nemade 2016-09-19 17:12:10 UTC
The Doc Text looks good to me. Thanks for writing it for this bug fix.

Comment 20 errata-xmlrpc 2016-11-04 07:51:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2520.html