Bug 1328484

Summary: liveusb-creator on Windows 10 opens diskpart.exe but does nothing
Product: [Fedora] Fedora Reporter: Jan Sedlák <jsedlak>
Component: liveusb-creatorAssignee: Luke Macken <lmacken>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 24CC: bcl, kparal, lmacken, mbriza, pfrields, robatino
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-04-26 07:33:53 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1230433, 1310542    
Description Flags
diskpart none

Description Jan Sedlák 2016-04-19 13:39:56 UTC
Created attachment 1148599 [details]

Description of problem:
When running newest version of liveusb-creator on 64bit Windows 10, writing to USB disk doesn't work. After downloading iso and clicking on "write to disk" button, it tries to open diskpart.exe (it's showing UAC warning on the background which is easily missable, see attached screenshot) and when I allow it, it shows diskpart.exe prompt, but does nothing more (see second screenshot).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run liveusb-creator.exe
2. Choose to write 64bit Fedora Workstation
3. After downloading, click on "write to disk"

Actual results:
diskpart.exe starts, but shows nothing more

Expected results:
it should use diskpart.exe to automatically partition disk

Comment 1 Jan Sedlák 2016-04-19 13:40:53 UTC
Created attachment 1148600 [details]

Comment 2 Kamil Páral 2016-04-20 10:13:29 UTC
Proposing as a Beta blocker, it seems to violate:
"Release-blocking live and dedicated installer images must boot when written to optical media of an appropriate size (if applicable) and when written to a USB stick with any of the officially supported methods."

That criterion doesn't really speak about which platforms the tool must correctly work on. But I assume that since FMR is intended to be a tool used also on Windows, the criterion should cover its functionality on Windows.

Comment 3 Kamil Páral 2016-04-22 07:14:04 UTC
This problem can be worked around if you right-click on the exe file and choose "Run as Administrator".

Comment 4 Martin Bříza 2016-04-22 15:43:20 UTC
Should be fixed in an updated version of the package on https://mbriza.fedorapeople.org/liveusb-creator.zip .
Sorry, still no version number included. Coming in the next build. Until then you can report dates from the archive.

Comment 5 Kamil Páral 2016-04-25 07:21:32 UTC
Works on my Windows 10.

Comment 6 Kamil Páral 2016-04-26 07:33:53 UTC
Verified on a second computer.