Bug 132899

Summary: 582 oops during "ifup lo"
Product: [Fedora] Fedora Reporter: Warren Togami <wtogami>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: bugproxy, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-09-23 16:55:29 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 130887    

Description Warren Togami 2004-09-18 19:27:18 EDT
Description of problem:
kernel oops during "ifup lo" on 582 kernel.  549 kernel on the same
hardware has no problems.


Unable to handle kernel paging request at virtual address 00100100
 printing eip:
022e96ab
*pde = 00000000
Oops: 0000 [#1]
Modules linked in: dm_mod button battery asus_acpi ac uhci_hcd
ehci_hcd sk98lin tulip ext3 jbd raid5 xor raid1 sata_via libata sd_mod
scsi_mod
CPU:    0
EIP:    0060:[<022e96ab>]    Not tainted VLI
EFLAGS: 00010206   (2.6.8-1.582)
EIP is at fib_find_info+0x53/0x10b
eax: 00000000   ebx: 00100100   ecx: 00000000   edx: 21301880
esi: 20c79380   edi: 20c79410   ebp: 20c79380   esp: 21fdedb8
ds: 007b   es: 007b   ss: 0068
Process netlink/0 (pid: 5, threadinfo=21fde000 task=21f30030)
Stack: 00000001 000000d0 00000000 02101fac 00000002 02101fac 21fdeea8
20c79410
       20c79380 022ea0f4 00000001 20c79380 ffffffed 21fdee58 21fdeea8
ffffffff
       21fdee58 21301840 20ad77e0 022eb7bd 21fdee30 02101fac 00000018
00000002
Call Trace:
 [<02101fac>] huft_build+0x218/0x442
 [<02101fac>] huft_build+0x218/0x442
 [<022ea0f4>] fib_create_info+0x3cb/0x50a
 [<022eb7bd>] fn_hash_insert+0xbd/0x408
 [<02101fac>] huft_build+0x218/0x442
 [<02101fac>] huft_build+0x218/0x442
 [<022e921b>] fib_magic+0xce/0xe2
 [<02101fac>] huft_build+0x218/0x442
 [<022e928b>] fib_add_ifaddr+0x5c/0x108
 [<02101fac>] huft_build+0x218/0x442
 [<02101fac>] huft_build+0x218/0x442
 [<022e94ca>] fib_inetaddr_event+0x16/0x50
 [<0212f349>] notifier_call_chain+0x17/0x2b
 [<022e214c>] inet_insert_ifa+0x109/0x110
 [<022e252c>] inet_rtm_newaddr+0x188/0x195
 [<022e23a4>] inet_rtm_newaddr+0x0/0x195
 [<022af1e3>] rtnetlink_rcv+0x225/0x313
 [<022ba0fd>] netlink_data_ready+0x14/0x43
 [<022b8e44>] netlink_wq_handler+0x10/0x2b
 [<021324c9>] worker_thread+0x21f/0x33d
 [<022b8e34>] netlink_wq_handler+0x0/0x2b
 [<0211b915>] default_wake_function+0x0/0xc
 [<0211b915>] default_wake_function+0x0/0xc
 [<021322aa>] worker_thread+0x0/0x33d
 [<021375f9>] kthread+0x69/0x91
 [<02137590>] kthread+0x0/0x91
 [<021041d9>] kernel_thread_helper+0x5/0xb
Code: 44 24 0c 8b 46 28 31 c2 89 44 24 08 89 d0 c1 e8 07 31 d0 c1 ea
0c 31 d0 8b 15 00 41 41 02 21 c8 8b 1c 82 85 db 0f 84 ae 00 00 00 <8b>
03 89 44 24 04 0f 18 00 90 8b 7b 5c 3b 3c 24 0f 85 8f 00 00


Hardware:
Athlon XP 2500+
Asus A7V600

00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP]
Host Bridge (rev 80)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:09.0 Ethernet controller: 3Com Corporation 3c940 10/100/1000Base-T
[Marvell] (rev 12)
00:0c.0 Ethernet controller: Linksys NC100 Network Everywhere Fast
Ethernet 10/100 (rev 11)
00:0d.0 RAID bus controller: Silicon Image, Inc. (formerly CMD
Technology Inc) PCI0680 Ultra ATA-133 Host Controller (rev 02)00:0e.0
Multimedia video controller: Internext Compression Inc iTVC16
(CX23416) MPEG-2 Encoder (rev 01)
00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA
RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [K8T800
South]
00:13.0 RAID bus controller: Silicon Image, Inc. (formerly CMD
Technology Inc) PCI0680 Ultra ATA-133 Host Controller (rev 02)01:00.0
VGA compatible controller: nVidia Corporation NV25 [GeForce4 Ti 4200]
(rev a3)

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.582
Comment 1 Warren Togami 2004-09-19 05:51:12 EDT
Whatever this problem is seems to be fixed in 2.6.9-rc2-bk4 when
compiled with 582's config.  It seems to solve my raid5 loopback ISO
mount kernel panic too.
Comment 2 Bill Nottingham 2004-09-20 12:26:16 EDT
*** Bug 132978 has been marked as a duplicate of this bug. ***
Comment 3 Arjan van de Ven 2004-09-23 16:55:29 EDT
fixed in 584
Comment 4 IBM Bug Proxy 2004-09-27 11:33:55 EDT
testing please ignore.
Comment 5 IBM Bug Proxy 2004-09-27 11:36:52 EDT
another test