Bug 1329814

Summary: Coin3 causes segfault in python-pivy
Product: [Fedora] Fedora Reporter: Richard Shaw <hobbes1069>
Component: Coin3Assignee: Ralf Corsepius <rc040203>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 24CC: rc040203
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Coin3-3.1.3-17.fc24 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-05-24 18:05:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1323159    

Description Richard Shaw 2016-04-23 12:17:33 UTC
Description of problem:
Coin3 causes a segfault in python-pivy due to aggressive optimization in gcc 6.

Version-Release number of selected component (if applicable):
Coin3-3.1.3-16.fc24


Steps to Reproduce:
1. Run interactive python
2. import pivy


Actual results:
Segmentation fault (core dumped)


Expected results:
Pivy imports normally


Additional info:
https://gcc.gnu.org/gcc-6/porting_to.html
Section:
More aggressive optimization of -flifetime-dse

Proposed patch/fix:
http://pkgs.fedoraproject.org/cgit/rpms/Coin3.git/tree/0012-memhandler-initialization.patch?id=ca89ec7227943bdec800ee51b920f578fab87b05

If there are no objections to this fix I would like to build for f24 at least but it may be best to rebuild on all supported releases.

Comment 1 Richard Shaw 2016-05-07 03:00:46 UTC
Per the nonresponsive maintainer policy I am requesting a response to this bug report.

Comment 2 Ralf Corsepius 2016-05-17 04:52:19 UTC
Richard, as you certainly know, I am not non-responsive. I just haven't managed to look into this bug.

Comment 3 Fedora Update System 2016-05-19 17:34:28 UTC
Coin3-3.1.3-17.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c1b3ae8058

Comment 4 Fedora Update System 2016-05-21 01:31:49 UTC
Coin3-3.1.3-17.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c1b3ae8058

Comment 5 Fedora Update System 2016-05-24 18:05:13 UTC
Coin3-3.1.3-17.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Richard Shaw 2016-05-25 18:18:45 UTC
Thanks for taking care of this Ralf.