Bug 133174
| Summary: | Wireless Config not working with WEP | ||
|---|---|---|---|
| Product: | [Fedora] Fedora | Reporter: | Jon Savage <jonathansavage> |
| Component: | kernel | Assignee: | Arjan van de Ven <arjanv> |
| Status: | CLOSED RAWHIDE | QA Contact: | Brian Brock <bbrock> |
| Severity: | medium | Docs Contact: | |
| Priority: | medium | ||
| Version: | 3 | CC: | marius.andreiana |
| Target Milestone: | --- | ||
| Target Release: | --- | ||
| Hardware: | i686 | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | Bug Fix | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2004-10-03 17:26:01 UTC | Type: | --- |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
applied all applicable updates as of 20:30 09/21/04 but the problem persists which module is the wireless driver? can you try to configure it by hand? First start it without a WEP key, then set the WEP key manually by: # iwconfig <interface> key 0x123456789 # iwconfig <interface> key restricted The module is likely orinco_cs (I don't know the correct cmd to see
which one applies, OK I'm dumb).
Output of iw config w/ WEP off & link working returns:
[jsavage@sw-lt01 ~]$ /sbin/iwconfig
lo no wireless extensions.
eth0 no wireless extensions.
sit0 no wireless extensions.
eth1 IEEE 802.11-DS ESSID:"foo_ws" Nickname:"sw-lt01"
Mode:Managed Frequency:2.412GHz Access Point:
XX:XX:XX:XX:XX:XX
Bit Rate=11Mb/s Tx-Power=15 dBm Sensitivity:1/3
Retry min limit:8 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=26/92 Signal level=-83 dBm Noise level=-140 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:203 Invalid misc:0 Missed beacon:0
running 'iw config eth1 key 0x123456' as root gives me:
[root@sw-lt01 ~]# iwconfig eth1 key 0x123456
Error for wireless request "Set Encode" (8B2A) :
invalid argument "0x123456".
So either I'm messing up <or> something else is...
JS
Ok... sorry!
# man iwconfig
....
To set the current encryption key, just enter the key in hex
digits as XXXX-XXXX-XXXX-XXXX or XXXXXXXX.
...
# iwconfig <interface> key 123456789
Thanks but I'd already tried that with the same result, Error for wireless request "Set Encode" (8B2A) : SET failed on device eth1 ; Invalid argument. this is definetly a kernel driver bug/missing feature. One last thing: does the interface have an IP address? # ifconfig eth1
Yep:
eth1 Link encap:Ethernet HWaddr xx:xx:xx:0D:28:FC
inet addr:192.168.1.105 Bcast:192.168.1.255
Mask:255.255.255.0
inet6 addr: fe80::20f:66ff:fe0d:28fc/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1154 errors:0 dropped:0 overruns:0 frame:0
TX packets:1215 errors:6 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:863797 (843.5 KiB) TX bytes:288826 (282.0 KiB)
Interrupt:3 Base address:0x180
Oh- In case I was unclear the card *does* function properly as long as WEP is not enabled. yes, but this is a kernel driver issue: Error for wireless request "Set Encode" (8B2A) : SET failed on device eth1 ; Invalid argument. It is working with all available updates applied so marking closed. |
From Bugzilla Helper: User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040808 Firefox/0.9.3 Description of problem: My wireless NIC (linksys wpc11 v.3) will only work with wep disabled on the WAP. The card worked fine with WEP enabled in both FC2 & FC3 T1. Version-Release number of selected component (if applicable): 1.3.20-1 How reproducible: Always Steps to Reproduce: 1.Attempt to configure wireless NIC using system-config-network 2.add WEP key in hex e.g. 0x123456789 3.Save config & attempt to activate the connection Actual Results: Attempted to activate the connection with WEP enabled, the application was unresponsive and had to be killed after several minutes. Expected Results: The connection should have become active witin a few seconds, gotten IP from DHCP etc Additional info: Fresh install of FC3 T2 on a compaq armada M700, selinix is turned on in default (targeted?) mode.