Bug 1332184

Summary: \c shortcut for changelog in vim seems to be broken
Product: [Fedora] Fedora Reporter: Ankur Sinha (FranciscoD) <sanjay.ankur>
Component: vimAssignee: Karsten Hopp <karsten>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 23CC: fszymanski, ignatenko, karsten, moshima.web, rdieter
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-09-14 08:13:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1297746    
Bug Blocks:    
Attachments:
Description Flags
example WIP spec none

Description Ankur Sinha (FranciscoD) 2016-05-02 12:53:01 UTC
Created attachment 1152950 [details]
example WIP spec

Description of problem:
The \c shortcut doesn't seem to be working any more. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. \c to insert a new change log entry
2.
3.

Actual results:
This is what I get when I hit \c:

Error detected while processing function <SNR>69_SpecChangelog[49]..<SNR>69_GetRelVer:                                                                                                                                                        
line   19:                                                                                                                                                                                                                                    
Traceback (most recent call last):                                                                                                                                                                                                            
  File "<string>", line 15, in <module>                                                                                                                                                                                                       
vim.error: Vim(let):E15: Invalid expression: 3.2b.hines18  

Expected results:
Should just add a new changelog entry. 

Additional info:
Attaching an example spec.

Comment 1 Rex Dieter 2016-05-02 12:57:12 UTC
I've seen similar issues on f24's vim occassionally too, can give more test-cases if that helps.

Comment 2 Karsten Hopp 2016-06-03 09:28:45 UTC
Unfortunately upstream spec.vim got more broken in the meantime. \c doesn't produce any useful results even in vim's own specfile anymore.

Comment 3 fszymanski 2016-06-03 22:13:20 UTC
Let's be honest about `spec.vim`. The code is not great. I wanted to add a few things but I decided to rewrite the whole plugin. Do something more like `rpm-spec-mode` in emacs. I should have something in a week or so.

Comment 4 Igor Gnatenko 2016-09-14 08:13:48 UTC

*** This bug has been marked as a duplicate of bug 1297746 ***