Bug 1333441

Summary: System not unlocking on extended monitors when using screensaver
Product: Red Hat Enterprise Linux 7 Reporter: jigar <jraising>
Component: kde-workspaceAssignee: Jan Grulich <jgrulich>
Status: CLOSED ERRATA QA Contact: Desktop QE <desktop-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.2CC: ajipatil, ayadav, jkoten
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-10 11:31:43 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1420851, 1479818    
Attachments:
Description Flags
comment #6 none

Description jigar 2016-05-05 13:59:03 UTC
Description of problem: On RHEL 7.2 Workstations using KDE, with 2 monitors connected, when using the Screen Locker "Simple locker" or "Screen saver" with the "Require password after" box checked, both monitors display a Password dialog to break screen lock, and both dialogs submit authentication requests.

Version-Release number of selected component (if applicable): kde-workspace-4.10.5-21.el7.x86_64

How reproducible: Always


Steps to Reproduce:
1. Go to System Settings -> Display & Monitor -> Screen Locker
2. Set "Require password After" to a non-null value
3. Wait till screen gets locked
4. Both the monitors require authentication

Actual results: Multiple Authentications are required to all the screens and "authentication failed" errors are recorded in /var/log/messages

Expected results: Single Authentication should unlock all the screens

Additional info: The issue is also reproducible upstream.

Comment 3 Jan Grulich 2017-04-19 06:26:11 UTC
Do you really have kde-workspace-4.10.5-21.el7.x86_64? I thought in RHEL 7.2 we have KDE 4.11. I tested this now with RHEL 7.3 and kde-workspace-4.11.19-x and this was working for me pretty well.

Comment 4 Ajinkya Patil 2017-05-03 01:43:57 UTC
Hello Jan,

I am checking with the customer about the same.

Comment 5 Ajinkya Patil 2017-05-04 01:51:54 UTC
Hello Jan,

We have this issue in RHEL7.3 as well. I have asked more information to get confirmation about the same.

Comment 7 Ajinkya Patil 2017-07-05 21:06:33 UTC
Created attachment 1294742 [details]
comment #6

Comment 10 Jan Grulich 2017-09-27 10:12:44 UTC
Fixed in kde-workspace-4.11.19-10.el7.

Comment 15 errata-xmlrpc 2018-04-10 11:31:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0717