Bug 1333823

Summary: python-landslide: Provide a Python 3 subpackage
Product: [Fedora] Fedora Reporter: Tomas Orsava <torsava>
Component: python-landslideAssignee: Eduardo Echeverria <echevemaster>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: dkrejci, echevemaster, ishcherb, jberan
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-landslide-1.1.3-6.fc25 python-landslide-1.1.3-6.fc26 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-03-29 01:30:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1285816, 1312032    
Attachments:
Description Flags
Spec file with a Python 3 subpackage
none
Spec file with a Python 3 package
none
Spec file with a Python 3 subpackage
none
Spec file with a Python 3 subpackage
none
Patch to fix python-landslide dependencies none

Description Tomas Orsava 2016-05-06 13:28:24 UTC
Upstream, this software supports Python 3. Please provide a Python 3
package for Fedora.


According to the Python packaging guidelines [0], software must be
packaged for Python 3 if upstream supports it.
The guidelines give detailed information on how to do this, and even
provide an example spec file [1].

The current best practice is to provide subpackages for the two Python
versions (called "Common SRPM" in the guidelines). Alternatively, if
nothing depends on your Python2 package, you can just switch to Python 3
entirely.

It's OK to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 24 as well.


If you need more instructions, a guide for porting Python-based RPMs is
available at [2].
If anything is unclear, or if you need any kind of assistance with the
porting, you can ask on IRC (#fedora-python on Freenode), or reply here.
We'll be happy to help!


[0] https://fedoraproject.org/wiki/Packaging:Python
[1] https://fedoraproject.org/wiki/Packaging:Python#Example_common_spec_file
[2] http://python-rpm-porting.readthedocs.io/

Comment 1 Dominika Krejčí 2016-06-28 09:53:55 UTC
Hi Eduardo, do you need some help with this?

Comment 2 Jan Kurik 2016-07-26 04:15:43 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 3 Jan Beran 2016-09-03 07:41:18 UTC
Hi Eduardo, I wondered to make a spec file patch to provide a Python 3 subpackage. However, I have just realized that last upstream commit was in 2015, and an active fork is available on PyPI [https://pypi.python.org/pypi/darkslide]. Would you consider to replace python-landslide by the fork?

Comment 4 Jan Beran 2016-10-18 14:22:41 UTC
Created attachment 1211762 [details]
Spec file with a Python 3 subpackage

Comment 5 Jan Beran 2016-10-31 08:34:50 UTC
Created attachment 1215718 [details]
Spec file with a Python 3 package

Comment 6 Jan Beran 2016-10-31 14:08:47 UTC
Created attachment 1215817 [details]
Spec file with a Python 3 subpackage

Proper subpackage naming

Comment 7 Jan Beran 2016-11-01 06:10:41 UTC
Created attachment 1215988 [details]
Spec file with a Python 3 subpackage

Comment 8 Fedora Update System 2017-02-22 19:32:00 UTC
python-landslide-1.1.3-5.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d2c12c146f

Comment 9 Fedora Update System 2017-02-23 23:21:08 UTC
python-landslide-1.1.3-5.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d2c12c146f

Comment 10 Iryna Shcherbina 2017-02-27 18:03:09 UTC
Created attachment 1258175 [details]
Patch to fix python-landslide dependencies

Hello Eduardo,

Jan's changes, proposed in the previous patch, were not fully applied, which resulted in two major problems with the package dependencies:

* the build produces python-landslide RPM (rather than python3-landslide) which is missing all runtime dependencies,

* the package now depends on both Python versions:

$ dnf --disablerepo=* --enablerepo=rawhide repoquery --requires python-landslide
/usr/bin/python
/usr/bin/python3
python(abi) = 3.6

Please see the change attached, that should fix the issues. It fixes the shebang to avoid generating dependency on Python 2 and packages the python3- subpackage, on which the runtime dependencies are defined.

Could you please review and apply the patch?

Comment 11 Fedora Update System 2017-03-20 15:08:12 UTC
python-landslide-1.1.3-6.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-771628a897

Comment 12 Fedora Update System 2017-03-20 15:14:51 UTC
python-landslide-1.1.3-6.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f4cc000f48

Comment 13 Fedora Update System 2017-03-21 05:21:42 UTC
python-landslide-1.1.3-6.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f4cc000f48

Comment 14 Fedora Update System 2017-03-21 14:25:14 UTC
python-landslide-1.1.3-6.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-771628a897

Comment 15 Fedora Update System 2017-03-29 01:30:46 UTC
python-landslide-1.1.3-6.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2017-04-01 17:17:15 UTC
python-landslide-1.1.3-6.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.