Bug 1333824

Summary: python-mailer: Provide a Python 3 subpackage
Product: [Fedora] Fedora Reporter: Tomas Orsava <torsava>
Component: python-mailerAssignee: Fabian Affolter <mail>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: athoscribeiro, mail, pviktori
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-27 12:14:52 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1322027    

Description Tomas Orsava 2016-05-06 13:28:40 UTC
Upstream, this software supports Python 3. Please provide a Python 3
package for Fedora.


According to the Python packaging guidelines [0], software must be
packaged for Python 3 if upstream supports it.
The guidelines give detailed information on how to do this, and even
provide an example spec file [1].

The current best practice is to provide subpackages for the two Python
versions (called "Common SRPM" in the guidelines). Alternatively, if
nothing depends on your Python2 package, you can just switch to Python 3
entirely.

It's OK to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 24 as well.


If you need more instructions, a guide for porting Python-based RPMs is
available at [2].
If anything is unclear, or if you need any kind of assistance with the
porting, you can ask on IRC (#fedora-python on Freenode), or reply here.
We'll be happy to help!


[0] https://fedoraproject.org/wiki/Packaging:Python
[1] https://fedoraproject.org/wiki/Packaging:Python#Example_common_spec_file
[2] http://python-rpm-porting.readthedocs.io/

Comment 1 Jan Kurik 2016-07-26 04:38:45 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 2 Athos Ribeiro 2016-07-26 19:36:26 UTC
Upstream is not fully ported to Python 3 as you can see in [1]: apparently there was a branch which was not merged with changes to support python 3 [2].

I only realized this after I prepared a python 3 subpackage for it and tried to manually test the new package, since I believe upstream does not provide a test suite

  File "/usr/lib/python3.5/site-packages/mailer.py", line 36, in <module>
    import Queue
ImportError: No module named 'Queue'

[1] https://bitbucket.org/ginstrom/mailer/commits/branch/default
[2] https://bitbucket.org/ginstrom/mailer/commits/76bfcbedd03ae06db434958dea204ce8e2829ce5?at=default

Comment 3 Tomas Orsava 2016-07-27 12:14:52 UTC
Hi Athos!
I wasn't aware that upstream is not fully ported yet, so I apologise for opening this bug! Hopefully it gets resolved upstream soon.