Bug 1334370

Summary: [RFE] Implied Roles
Product: Red Hat OpenStack Reporter: Maxime Payant-Chartier <mpayantc>
Component: openstack-keystoneAssignee: John Dennis <jdennis>
Status: CLOSED ERRATA QA Contact: Rodrigo Duarte <rduartes>
Severity: high Docs Contact:
Priority: high    
Version: 9.0 (Mitaka)CC: acanan, jdennis, kbasil, nkinder, nlevinki, rcritten, sclewis, srevivo
Target Milestone: Upstream M3Keywords: FutureFeature, Triaged
Target Release: 11.0 (Ocata)   
Hardware: Unspecified   
OS: Unspecified   
URL: https://blueprints.launchpad.net/keystone/+spec/implied-roles
Whiteboard: upstream_milestone_mitaka-3 upstream_definition_approved upstream_status_implemented
Fixed In Version: openstack-keystone-11.0.0-0.20170114233131.d6410bf.el7ost Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-17 19:29:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1421552    

Description Maxime Payant-Chartier 2016-05-09 12:54:36 UTC
Clone from blueprint: https://blueprints.launchpad.net/keystone/+spec/implied-roles

Description of problem:

 When assignment of a superior role, user will also be assigned all roles implied by any prior roles The hierarchy of the roles will be expanded when issuing a token.

Comment 7 errata-xmlrpc 2017-05-17 19:29:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245