Bug 1334374

Summary: [RFE] reseller (phase 1): top level projects as domains
Product: Red Hat OpenStack Reporter: Maxime Payant-Chartier <mpayantc>
Component: openstack-keystoneAssignee: John Dennis <jdennis>
Status: CLOSED ERRATA QA Contact: Rodrigo Duarte <rduartes>
Severity: high Docs Contact:
Priority: high    
Version: 9.0 (Mitaka)CC: acanan, jdennis, kbasil, nkinder, nlevinki, rcritten, sclewis, srevivo
Target Milestone: Upstream M3Keywords: FutureFeature, Triaged
Target Release: 11.0 (Ocata)   
Hardware: Unspecified   
OS: Unspecified   
URL: https://blueprints.launchpad.net/keystone/+spec/reseller
Whiteboard: upstream_milestone_mitaka-3 upstream_definition_approved upstream_status_implemented
Fixed In Version: openstack-keystone-11.0.0-0.20170114233131.d6410bf.el7ost Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-17 19:30:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1421553    

Description Maxime Payant-Chartier 2016-05-09 13:03:49 UTC
Clone from upstream blueprint: https://blueprints.launchpad.net/keystone/+spec/reseller

Description of problem:

Implementing a support to limit sharing of resources both upwards and downwards in the hierarchy.
To achieve this, the domains construct will be merged with project, allowing to distribute users in any point of the hierarchy, instead of only in a single domain.

This blueprint covers the 1st phase of reseller, where projects can act as a domain, but only as a top level domain - i.e. no sub domains are allowed. A separate blueprint & spec will cover the augmentation of this to allow sub domains.

Comment 6 errata-xmlrpc 2017-05-17 19:30:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245