Bug 1334749

Summary: sssd fails to mark a connection as bad on searches that time out
Product: Red Hat Enterprise Linux 7 Reporter: Thorsten Scherf <tscherf>
Component: sssdAssignee: SSSD Maintainers <sssd-maint>
Status: CLOSED ERRATA QA Contact: Steeve Goveas <sgoveas>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.2CC: grajaiya, jhrozek, lslebodn, mkosek, mzidek, pbrezina, sgadekar
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: sssd-1.14.0-3.el7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-11-04 07:18:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Thorsten Scherf 2016-05-10 12:47:03 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/sssd/ticket/3009

In case you have multiple servers defined in sssd.conf, it might happen that no failover takes place. When a connection to one server can be established and port 389 is reachable, but when the ldap search times out, sssd does not mark the connection as bad and keeps talking to this server instead of failing over to any of the other servers defined in the configuration.

Comment 1 Jakub Hrozek 2016-07-12 10:02:36 UTC
* master: c420ce830ac0b0b288a2a887ec2cfce5c748018c

Comment 5 errata-xmlrpc 2016-11-04 07:18:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2476.html