Bug 1335074

Summary: The endpoints information didn't be removed from haproxy.config when service is deleted
Product: OpenShift Container Platform Reporter: zhaozhanqi <zzhao>
Component: RoutingAssignee: Phil Cameron <pcameron>
Status: CLOSED ERRATA QA Contact: zhaozhanqi <zzhao>
Severity: medium Docs Contact:
Priority: medium    
Version: 3.2.0CC: aos-bugs, bperkins, tdawson
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-09-27 09:32:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description zhaozhanqi 2016-05-11 09:54:50 UTC
Description of problem:
The endpoint information didn't be removed from haproxy.config when service and pod is deleted.
please note, first delete service and then delete pod.

I'm afraid at this time another people create one pod with IP is same as above pod

example:
user A create pod/service/route and assume pod ip is (10.129.0.2). now A delete service firstly and then delete pod. the route will cannot be accessed. but the endpoints information still exist in haproxy.config.

Check the haproxy.config:
<--snip-->
server 302789aed6899093dadb89a311076244 10.129.0.2:8080 check inter 5000ms cookie 302789aed6899093dadb89a311076244
<--snip-->

now user B create one pod and the pod IP is just to (10.129.0.2). 

then user A can access his route to user B's Pod


Version-Release number of selected component (if applicable):
oc v3.2.0.43
kubernetes v1.2.0-36-g4a3f9c5

How reproducible:
always


Steps to Reproduce:
1. Given the haproxy router is running
2. create pod/service/router in project test
3. Delete the service
4. Delete the pod
5. check the haproxy.config in router container

Actual results:

As $Description

Expected results:

the endpoints information should be removed once the service is deleted.

Additional info:

Comment 2 Phil Cameron 2016-06-27 15:02:26 UTC
Fixed bug and fixed test case PR9408

Comment 3 Phil Cameron 2016-06-30 18:06:25 UTC
https://github.com/openshift/origin/pull/9408

Comment 4 Phil Cameron 2016-07-07 12:41:29 UTC
openshift/origin/pr9408  -- merged and closed.

Comment 5 Troy Dawson 2016-07-20 22:18:51 UTC
This has been merged and is in OSE v3.3.0.8 or newer.

Comment 6 zhaozhanqi 2016-07-21 07:40:19 UTC
verified this bug on 

openshift version
openshift v3.3.0.8
kubernetes v1.3.0+57fb9ac
etcd 2.3.0+git

Comment 8 errata-xmlrpc 2016-09-27 09:32:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933