Bug 1336243

Summary: minetest-0.4.14 is available
Product: [Fedora] Fedora Reporter: Upstream Release Monitoring <upstream-release-monitoring>
Component: minetestAssignee: Aleksandra Fedorova <alpha>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: alpha, ignatenko, oliver, rosser.bjr, ufa
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: minetest-0.4.14-1.fc24 minetest-0.4.14-1.el7 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-06-30 21:28:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
none
Patch for building package for 0.4.14 none

Description Upstream Release Monitoring 2016-05-16 00:17:01 UTC
Latest upstream release: 0.4.14
Current version/release in rawhide: 0.4.13-5.fc25
URL: https://github.com/minetest/minetest

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/1978/

Comment 1 Upstream Release Monitoring 2016-05-16 00:17:31 UTC
Patching or scratch build for minetest-0.4.13 failed.

Comment 2 Upstream Release Monitoring 2016-05-16 00:17:33 UTC
Created attachment 1157741 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.

Comment 3 Upstream Release Monitoring 2016-05-16 00:17:34 UTC
Patches were not touched. All were applied properly

Comment 4 Ben Rosser 2016-06-21 18:35:16 UTC
Created attachment 1170367 [details]
Patch for building package for 0.4.14

Comment 5 Ben Rosser 2016-06-21 18:36:38 UTC
I've created a patch that should fix the build on 0.4.14; the following things broke:

* upstream removed the bundled jthread (yay); but the %license macro referred to a copy of jthread's license, which no longer exists.

* a documentation file was renamed, or at least that's what it looks like (mapformat.txt to world_format.txt). At the very least, doc/mapformat.txt is no longer there.

* minetest-icon.svg was renamed to minetest.svg.

Comment 6 Upstream Release Monitoring 2016-06-21 19:18:49 UTC
ignatenkobrain's minetest-0.4.14-1.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=774539

Comment 7 Fedora Update System 2016-06-21 19:38:21 UTC
minetest-0.4.14-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c3c8ec8c2e

Comment 8 Fedora Update System 2016-06-22 23:03:25 UTC
minetest-0.4.14-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c3c8ec8c2e

Comment 9 Fedora Update System 2016-06-22 23:38:20 UTC
minetest-0.4.14-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-729eb6a199

Comment 10 Fedora Update System 2016-06-24 02:19:59 UTC
minetest-0.4.14-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-729eb6a199

Comment 11 Fedora Update System 2016-06-30 21:28:15 UTC
minetest-0.4.14-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-07-10 02:20:43 UTC
minetest-0.4.14-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.