Bug 1336433

Summary: Openstack installation fails due to invalid firewall driver parameter
Product: Red Hat OpenStack Reporter: Alexander Stafeyev <astafeye>
Component: openstack-packstackAssignee: Ivan Chavero <ichavero>
Status: CLOSED ERRATA QA Contact: Mike Burns <mburns>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 9.0 (Mitaka)CC: aortega, apevec, astafeye, ichavero, jschluet, mburns, nlevinki, sgordon, srevivo, tshefi
Target Milestone: rcKeywords: Triaged
Target Release: 10.0 (Newton)   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: openstack-packstack-9.0.0-0.20160922140727.3f43120.1.el7ost Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-12-14 15:33:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Alexander Stafeyev 2016-05-16 13:03:34 UTC
Description of problem:
Installation fails due to following: 

10.35.99.5_neutron.pp:                            [ ERROR ]      
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 10.35.99.5_neutron.pp
Error: Invalid parameter firewall_driver on Class[Neutron::Plugins::Ml2] at /var/tmp/packstack/d3eebddbbc734b0d83aaaf93efb98547/manifests/10.35.99.5_neutron.pp:131 on node rose11.qa.lab.tlv.redhat.com
You will find full trace in log /var/tmp/packstack/20160516-150155-bllNaU/manifests/10.35.99.5_neutron.pp.log




Version-Release number of selected component (if applicable):
rhos 9
openstack-packstack-puppet-8.0.0-1.el7ost.noarch
openstack-packstack-8.0.0-1.el7ost.noarch



How reproducible:

100%

Steps to Reproduce:
1.deploy osp 9 with default answerfile values 
2.
3.

Actual results:
installation fails 

Expected results:
installatio nshould be successful 

Additional info:


# cat /var/tmp/packstack/latest/manifests/10.35.99.5_neutron.pp | grep firewall
  firewall_driver           => hiera('FIREWALL_DRIVER'),
create_resources(packstack::firewall, hiera('FIREWALL_NEUTRON_SERVER_RULES', {}))
create_resources(packstack::firewall, hiera('FIREWALL_NEUTRON_TUNNEL_RULES_10.35.99.5_10.35.99.5', {}))
  firewall_driver  => hiera('FIREWALL_DRIVER'),
create_resources(packstack::firewall, hiera('FIREWALL_NEUTRON_DHCPIN_RULES', {}))
create_resources(packstack::firewall, hiera('FIREWALL_NEUTRON_DHCPOUT_RULES', {}))


# cat /var/tmp/packstack/latest/manifests/10.35.99.5_neutron.pp.log 
Warning: Scope(Class[Neutron::Server]): identity_uri, auth_tenant, auth_user, auth_password, auth_region configuration options are deprecated in favor of auth_plugin and related options
Error: Invalid parameter firewall_driver on Class[Neutron::Plugins::Ml2] at /var/tmp/packstack/d3eebddbbc734b0d83aaaf93efb98547/manifests/10.35.99.5_neutron.pp:131 on node rose11.qa.lab.tlv.redhat.com
Wrapped exception:
Invalid parameter firewall_driver
Error: Invalid parameter firewall_driver on Class[Neutron::Plugins::Ml2] at /var/tmp/packstack/d3eebddbbc734b0d83aaaf93efb98547/manifests/10.35.99.5_neutron.pp:131 on node rose11.qa.lab.tlv.redhat.com

Comment 3 Ivan Chavero 2016-05-20 19:09:27 UTC
Hello, i haven't been able to reproduce your problem. Can you give me access to the system?

Comment 7 Alexander Stafeyev 2016-05-30 04:34:36 UTC
You are correct. 
I managed to deploy when CONFIG_NEUTRON_L3_EXT_BRIDGE=br-ex and not "provider" 

Is "CONFIG_NEUTRON_L3_EXT_BRIDGE=provider the firewall puppet module does not accept this value." is a know issue? We did not encounter it in previous versions. 

Regarding the original issue- may be it can be reproduced on the same puddle.
If on latest puddle , after fixing the "provider" value for "CONFIG_NEUTRON_L3_EXT_BRIDGE" the original issue will not be reproduced, we will need to decide if we want to try to chase it.

BR

Comment 8 Ivan Chavero 2016-06-02 19:21:51 UTC
I'm checking what's the  best option

Comment 9 Jon Schlueter 2016-08-30 15:49:32 UTC
are we waiting on anything other than the mentioned patch?

Comment 10 Ivan Chavero 2016-10-03 20:37:36 UTC
we already have the package for this bug: openstack-packstack-9.0.0-0.20160922140727.3f43120.1.el7ost

Comment 14 errata-xmlrpc 2016-12-14 15:33:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html