Bug 1336951

Summary: l2tp connection fails to start
Product: [Fedora] Fedora Reporter: Vadim Raskhozhev <iamdexpl>
Component: NetworkManager-l2tpAssignee: Ivan Romanov <drizt72>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 24CC: doug, drizt72, psimerda
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-06-22 06:48:26 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Vadim Raskhozhev 2016-05-17 21:23:32 UTC
Description of problem:

My ISP provides the Internet through l2tp vpn and it's been working for years. Recently I updated Fedora to not-yet-released 24 and found that NetworkManager-l2tp fails to start saying '<warn>  [1463430382.6571] vpn-connection[0x56203d44b200,9b218a64-7248-4b8c-9dd3-dea859389abb,"beeline-l2tp",0]: Timed out waiting for the service to start' in NetworkManager.service log. After downgrading NetworkManager to .fc23 it is running well again.

The connection in question:

[connection]
id=beeline-l2tp
uuid=9b218a64-7248-4b8c-9dd3-dea859389abb
type=vpn
autoconnect=false
permissions=
secondaries=
timestamp=1463166479

[vpn]
gateway=tp.internet.beeline.ru
require-mppe=yes
user=<Correct login name>
password-flags=0
service-type=org.freedesktop.NetworkManager.l2tp

[vpn-secrets]
password=<Correct password>

[ipv4]
dns-search=
ignore-auto-dns=true
may-fail=false
method=auto
route-metric=0

[ipv6]
dns-search=
ip6-privacy=0
method=ignore

(cutting off username and password values due to obvious reason; deadly sure they are correct)

Version-Release number of selected component (if applicable):

NetworkManager-1.2.2-1.fc24.x86_64.rpm
NetworkManager-l2tp-1.2.0-1.fc24.x86_64.rpm
(do not work; maybe NM-l2tp-1.2.2 would?)

NetworkManager-1.0.12-2.fc23.x86_64.rpm
NetworkManager-l2tp-0.9.8.7-4.fc23.x86_64.rpm
(do work; actually, I downgraded all the NM-stuff from `rpm -qa --qf '%{name} ' NetworkManager\*`)

Comment 1 Douglas Kosovic 2016-05-31 04:22:49 UTC
I've taken over maintaining the NetworkManager-l2tp source code :
  https://github.com/nm-l2tp/network-manager-l2tp

For NetworkManager 1.0 based Fedora 23, you need to use NetworkManager-l2tp version 1.0.2. Versions before 1.0.0 won't work.

For NetworkManager 1.2 based Fedora 24, you need to use NetworkManager-l2tp version 1.2.2. Version 1.2.0 had issues.

There are issues contacting the NetworkManager-l2tp RPM maintainer as his email address bounces. So I emailed someone else.


My update request for NetworkManager-l2tp to 1.2.2 on Fedora 24 :
  https://bugzilla.redhat.com/show_bug.cgi?id=1336282
and the RPM has been pushed to the Fedora 24 testing repository.

As for Fedora 23, keep your eye on the bottom of the following:
  https://bugzilla.redhat.com/show_bug.cgi?id=887674

With the new RPMs, be sure to also install NetworkManager-l2tp-gnome

Comment 2 Douglas Kosovic 2016-06-22 06:48:26 UTC
NetworkManager-l2tp 1.2.2-1.fc24 and 1.0.2-2.fc24 RPMs should resolve the issues.

Minor correction to what I wrote in my previous comment:

For IPsec support on Fedora 23, NetworkManager-l2tp versions before 1.0.0 won't work, but L2TP support was okay.