Bug 1337340

Summary: [RFE][swift]: Erasure coding support
Product: Red Hat OpenStack Reporter: Sean Cohen <scohen>
Component: openstack-swiftAssignee: Pete Zaitcev <zaitcev>
Status: CLOSED ERRATA QA Contact: Mike Abrams <mabrams>
Severity: medium Docs Contact: Don Domingo <ddomingo>
Priority: high    
Version: unspecifiedCC: cschwede, ddomingo, derekh, egafford, jdonohue, jschluet, mabrams, markmc, nlevinki, pgrist, rhos-integ, robert.h.armstrong, sclewis, scohen, sgordon, sgotliv, srevivo, yeylon, zaitcev
Target Milestone: rcKeywords: FutureFeature, Triaged
Target Release: 10.0 (Newton)   
Hardware: Unspecified   
OS: Unspecified   
URL: https://blueprints.launchpad.net/swift/+spec/swift-ec
Whiteboard: upstream_milestone_ongoing upstream_status_started upstream_definition_approved
Fixed In Version: openstack-swift-2.8.1-0.20160621180609.c0217a4.el7ost Doc Type: Technology Preview
Doc Text:
Story Points: ---
Clone Of: 1041510
: 1377511 (view as bug list) Environment:
Last Closed: 2016-12-14 15:33:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1041510    
Bug Blocks: 1334442, 1335593, 1342156, 1377511    

Comment 1 Sean Cohen 2016-06-08 12:31:26 UTC
*** Bug 1343769 has been marked as a duplicate of this bug. ***

Comment 2 Sean Cohen 2016-06-08 12:42:59 UTC
Hi Robert,
What about the Intel's Intelligent Storage Acceleration Library support?
Sean

Comment 3 Rob Armstrong 2016-06-08 20:19:32 UTC
thanks Sean.  

Sounds like we would want support for EC both with and without ISAL.  As it was explained to me:  "default for Swift is a non-IA specific implementation of EC. To enable ISAL it has to be installed and then Swift has to be manually configured to use it.  Note that in general replication is the default for Swift, you have to manually ‘turn on’ EC and if you want ISA-L install/configure it as well."

Do I need to figure out where ISAL is supported by RHEL?

Rob

Comment 4 Elise Gafford 2016-09-08 15:56:09 UTC
Hi Pete,

Please add the fixed-in-version in which this change is built and set to MODIFIED to move to QE.

Comment 5 Elise Gafford 2016-09-08 15:56:53 UTC
Hi Mike,

Please qa_ack+ this, as it is currently within our plan to ship this in RHOS 10.

Comment 14 errata-xmlrpc 2016-12-14 15:33:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html