Bug 1339449

Summary: [RFE] Improved broker logging for expired messages
Product: Red Hat Enterprise MRG Reporter: Mike Cressman <mcressma>
Component: qpid-cppAssignee: Gordon Sim <gsim>
Status: CLOSED ERRATA QA Contact: Messaging QE <messaging-qe-bugs>
Severity: high Docs Contact:
Priority: medium    
Version: 3.2CC: esammons, iboverma, jross, mcressma, tkratky, zkraus
Target Milestone: 3.2.2Keywords: FutureFeature, Patch
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: qpid-cpp-0.34-12 Doc Type: Enhancement
Doc Text:
Feature: Improved broker logging for expired messages Reason: Messages that are expired by the queue cleaner are not logged as they used to be. Logging should include the queue name and the message properties. Result (if any): Logging is moved to a common place in the source module so all expired messages receive the same logging treatment. The queue name and message properties are included in debug-level log entries.
Story Points: ---
Clone Of: 866677 Environment:
Last Closed: 2016-10-11 07:36:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 866677    
Bug Blocks: 698367    

Comment 1 Mike Cressman 2016-05-25 05:02:36 UTC
We added this feature downstream to MRG-M 2, but it never made it upstream, so it is not in MRG-M 3.  Customer has requested we add to MRG-M 3 (same functionality as currently in MRG-M 2.

Comment 2 Gordon Sim 2016-05-25 07:05:32 UTC
Fixed upstream: https://svn.apache.org/r1745448

Comment 7 errata-xmlrpc 2016-10-11 07:36:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2049.html