Bug 1339619

Summary: [RFE] Quick Installer, should have a Generate Option
Product: OpenShift Container Platform Reporter: Eric Rich <erich>
Component: RFEAssignee: Devan Goodwin <dgoodwin>
Status: CLOSED ERRATA QA Contact: Johnny Liu <jialiu>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 3.2.0CC: anli, aos-bugs, dgoodwin, jokerman, mmccomas, tdawson
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-09-27 09:33:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Eric Rich 2016-05-25 13:06:03 UTC
Description of problem:

The OpenShift Quick Installer, should not only have a install, uninstall, and update option, but it should also have a generate option (where it completes) all the wrapper steps, but only generates a hosts file that can be used/modified for use with the advanced install instructions of the documentation.

Comment 1 Devan Goodwin 2016-07-12 18:15:16 UTC
This was actually implemented a little while ago, and is now shipping with 3.2.

atomic-openshift-installer install --gen-inventory.

Wrote atomic-openshift-installer config: /home/dgoodwin/.config/openshift/installer.cfg.yml
Wrote ansible inventory: /home/dgoodwin/.config/openshift/hosts

Comment 2 Anping Li 2016-07-13 01:40:39 UTC
Some issue found during testing
1) There are no help info

2) The option --gen-inventory must be place behind command. it is different with other options (such as -c, -u and etc)

3) if the configuration is current directory(-c test.yaml), The inventory file will be /hosts. it should be hosts

#The output is as following
<---snip--->
Wrote atomic-openshift-installer config: test.yaml
Wrote ansible inventory: /hosts

Comment 3 Anping Li 2016-08-01 03:07:00 UTC
To Following REF bug proccess, QA can't move status to this bug. So I will open a new bug for the comment 2.

Comment 5 errata-xmlrpc 2016-09-27 09:33:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933