Bug 1340526

Summary: Starting builds fails since today
Product: [Fedora] Fedora Reporter: Heiko Adams <bugzilla>
Component: copr-cliAssignee: Miroslav Suchý <msuchy>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 24CC: clime, fedora, jkadlcik, mlichvar, msuchy, praiskup
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-05-30 12:55:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Heiko Adams 2016-05-27 17:34:14 UTC
Description of problem:
I don't know why but since today all attempts to build a package are failing with
> Something went wrong:
> Error: Invalid request: bad request parameters: {'source_type': [u'Invalid value, must be one of: srpm_upload.']}

Version-Release number of selected component (if applicable):
$ rpm -q copr-cli
copr-cli-1.50-1.fc24.noarch

How reproducible:
allways

Steps to Reproduce:
1. Start a new build using copr-cli and submit a local package or one which is saved on a public accessible location
2.
3.

Actual results:
Starting the build fails

Expected results:
copr build should be started

Additional info:

Comment 1 Remi Collet 2016-05-30 05:50:20 UTC
Same issue since May 28th (on EL-6)

Don't know is this is related to copr-cli, as (from yum.log)

    May 26 16:06:29 Updated: python-copr-1.68-1.el6.noarch
    May 26 16:06:33 Updated: copr-cli-1.50-1.el6.noarch

And nigthly build run May 27th is ok https://copr.fedorainfracloud.org/coprs/remi/qelectrotech/build/317432/

But, since May 28th

$ copr-cli build --nowait \
    qelectrotech \
    http://remi.famillecollet.com/qelectrotech-0.51-0.6.svn4535.el6.src.rpm

Something went wrong:
Error: Invalid request: bad request parameters: {'source_type': [u'Invalid value, must be one of: srpm_link.']}

Comment 2 Miroslav Lichvar 2016-05-30 12:39:06 UTC
I saw this with copr-cli-1.47-1.fc23, update to 1.50-1 didn't help.

Comment 3 Miroslav Suchý 2016-05-30 12:55:15 UTC
Please use python-copr and copr-cli from updates testing.

*** This bug has been marked as a duplicate of bug 1340650 ***