Bug 134092

Summary: /sbin/start_udev unexpected } in line 79
Product: [Fedora] Fedora Reporter: Clyde E. Kunkel <clydekunkel7734>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3CC: be, bobgus
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: udev-032-8 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-04 09:59:15 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
boot log from today
none
messages from today's boot attempts
none
X log from today
none
another X log from today none

Description Clyde E. Kunkel 2004-09-29 12:14:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
during reboot of FC3T2 after latest update this AM, got msg
/sbin/start_udev unexpected } in line 79.  Then get a series of error
msgs that went by too fast to catch.  On this multi-boot computer,
booted into FC2 and in /var/log/messages saw a lot of X failures. 
Will attach todays messages and boot logs.

Result is that a graphical logon never appears.  Can blindly logon,
then blindly C-A-F2 and blindly logon as root then reboot.

Version-Release number of selected component (if applicable):
udev-032-2

How reproducible:
Always

Steps to Reproduce:
1.boot latest FC3T2
2.
3.
    

Actual Results:  Never got a graphical logon screen.

Expected Results:  Normal logon

Additional info:

Downgraded to libbonoboui-2.8.0-1 yesterday to fix Evolution and
eggcups problems.
Comment 1 Clyde E. Kunkel 2004-09-29 12:21:18 EDT
Created attachment 104515 [details]
boot log from today

Shows various efforts to boot today.
Comment 2 Clyde E. Kunkel 2004-09-29 12:22:12 EDT
Created attachment 104517 [details]
messages from today's boot attempts
Comment 3 Clyde E. Kunkel 2004-09-29 12:22:42 EDT
Created attachment 104518 [details]
X log from today
Comment 4 Clyde E. Kunkel 2004-09-29 12:23:16 EDT
Created attachment 104519 [details]
another X log from today
Comment 5 Clyde E. Kunkel 2004-09-29 13:42:48 EDT
Can boot into runlevel 3 to do maintenance work.  startx goes to blank
screen and keyboard is lifeless.
Comment 6 David Lawrence 2004-09-29 13:47:16 EDT
There is a missing 'fi' line in start_udev that when added back fixes
this error allowing machine to boot fine.

mount_udev() {
    if [ -z "$SELINUX" ]; then
        if [ -n "$selinuxfs" ] && [ "`cat /proc/self/attr/current`" !=
"kernel" ]; then
            if [ -r $selinuxfs/enforce ] ; then
                SELINUX=`cat $selinuxfs/enforce`
            else
                # assume enforcing if you can't read it
                SELINUX=1
            fi
        fi
    fi

        ^^ omitted 'fi'
Comment 7 Clyde E. Kunkel 2004-09-29 14:23:03 EDT
Made the change.  No longer see the start_udev error, but still get
the X failures.  Can still go into runlevel 3 on boot and can get to
FC3T2 partition from FC2.  SELinux was and is turned off.
Comment 8 Bill Nottingham 2004-09-29 17:18:07 EDT
Syntax error fixed in 032-5.
Comment 9 Bill Nottingham 2004-09-29 17:18:28 EDT
*** Bug 134161 has been marked as a duplicate of this bug. ***
Comment 10 Clyde E. Kunkel 2004-09-29 18:26:26 EDT
I did an interactive boot so I could see and record some of the
messages that don't show in the logs and saw the following:

starting mDNSResponder... /etc/profile: line 27: /dev/null: Permission
denied
/etc/profile.d/colorls.sh: line 3: /dev/null: Permission denied
 
(above msg wa repeated for lines 4, 17, 18, 19 and 20)
 
/etc/profile.d/vim.sh: line 3: /dev/null: Permission denied
[howl] unable to daemonize (3419)
 .
 .
 .
 starting atd:  [FAILED]

Did the bad udev corrupt something else?
 
Comment 11 Clyde E. Kunkel 2004-09-29 21:08:03 EDT
Downgraded udev to 032-2.  Strange that the patch above didn't work. 
Wonder what caused all the problems.
Comment 12 Nick Atkins 2004-09-30 01:00:34 EDT
I added the 'fi' in the right place and everything now works for me. 
I'm using 2.8.1 kernel build 590.
Comment 13 Harald Hoyer 2004-09-30 05:20:35 EDT
udev-032-5 should work
Comment 14 Arnyek Andras 2004-09-30 09:17:40 EDT
i'm installed udev-032-5 and reboot, then get this:

Making extra nodes: cp: cannot stat '/etc/udev/devices/*': No such 
file or directory

Starting udev: [FAILED]
Comment 15 Harald Hoyer 2004-09-30 09:22:22 EDT
comment #14 is fixed in udev-032-6
Comment 16 David Lawrence 2004-09-30 13:29:50 EDT
*** Bug 134255 has been marked as a duplicate of this bug. ***
Comment 17 Clyde E. Kunkel 2004-09-30 18:20:51 EDT
Except for comment 13, 032-5 is working fine for me.
Comment 18 Bernhard Erdmann 2004-09-30 19:20:10 EDT
except from comment #14 (Making extra nodes: cp: cannot stat
'/etc/udev/devices/*': No such file or directory), udev-032-5 works for me