Bug 1346040

Summary: audacity: Crash at start when run on Gnome Wayland
Product: [Fedora] Fedora Reporter: Nicolas Dufresne <nicolas>
Component: audacityAssignee: David Timms <dtimms>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 24CC: dtimms, fedora2018q2, havill, moez.roy, swt, zxy_thf
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: audacity-2.1.3-0.7.20161109git53a5c93.fc25 audacity-2.1.3-0.7.20161109git53a5c93.fc24 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-11-24 16:28:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1277927    

Description Nicolas Dufresne 2016-06-13 18:17:02 UTC
Description of problem:
Audacity crash at start on Gnome Wayland (XWayland).

Version-Release number of selected component (if applicable):
audacity-2.1.2-4.fc24.x86_64

How reproducible:
Just run audacity.

Actual results:
Crash.

Expected results:
The UI to start.

Additional info:


#0  0x00007ffff0736a06 in strlen () at ../sysdeps/x86_64/strlen.S:106
#1  0x00007ffff1adb893 in g_strdup (str=str@entry=0x54 <error: Cannot access memory at address 0x54>) at gstrfuncs.c:362
#2  0x00007fffd521bc45 in CORBA_Context_set_one_value (ctx=0x555556463320, prop_name=prop_name@entry=0x7fffd6faabaf "display", value=0x54 <error: Cannot access memory at address 0x54>, ev=ev@entry=0x7fffffffdb60) at corba-context.c:115
#3  0x00007fffd6f79b06 in do_low_level_init () at bonobo-ui-main.c:197
#4  0x00007fffd5fb00ae in gnome_program_postinit (program=0x5555563e28e0 [GnomeProgram]) at gnome-program.c:1835
#5  0x00007fffd5fb047a in gnome_program_init_common (type=93825007474224, app_id=app_id@entry=0x5555563af200 "Audacity", app_version=app_version@entry=0x555555eb5b89 "1.0", module_info=module_info@entry=0x7fffd745f360 <module_info>, argc=argc@entry=1, argv=argv@entry=0x55555634a028 <GnomeShutdownInstance+8>, first_property_name=0x0, args=0x7fffffffdc80, nparams=-1, params=0x0) at gnome-program.c:2072
#6  0x00007fffd5fb0695 in gnome_program_initv (type=<optimized out>, app_id=app_id@entry=0x5555563af200 "Audacity", app_version=app_version@entry=0x555555eb5b89 "1.0", module_info=module_info@entry=0x7fffd745f360 <module_info>, argc=argc@entry=1, argv=argv@entry=0x55555634a028 <GnomeShutdownInstance+8>, first_property_name=0x0, args=0x7fffffffdc80) at gnome-program.c:2109
#7  0x00007fffd5fb076f in gnome_program_init (app_id=0x5555563af200 "Audacity", app_version=0x555555eb5b89 "1.0", module_info=0x7fffd745f360 <module_info>, argc=1, argv=0x55555634a028 <GnomeShutdownInstance+8>, first_property_name=0x0) at gnome-program.c:1888
#8  0x0000555555956d34 in GnomeShutdown::GnomeShutdown() (this=0x55555634a020 <GnomeShutdownInstance>) at AudacityApp.cpp:556
#9  0x00005555558e27ee in _GLOBAL__sub_I_EVT_OPEN_AUDIO_FILE() (__initialize_p=1, __priority=65535) at AudacityApp.cpp:583
#10 0x00005555558e27ee in _GLOBAL__sub_I_EVT_OPEN_AUDIO_FILE() () at AudacityApp.cpp:2081
#11 0x0000555555e374c3 in __libc_csu_init ()
#12 0x00007ffff06ce6c0 in __libc_start_main (main=0x5555558e2780 <main(int, char**)>, argc=1, argv=0x7fffffffdf08, init=
    0x555555e37470 <__libc_csu_init>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffffffdef8) at ../csu/libc-start.c:245
#13 0x000055555590b499 in _start ()

Comment 1 Nicolas Dufresne 2016-06-13 18:23:24 UTC
It works if one force the GDK backend to X11

  GDK_BACKEND=x11 audacity

Comment 2 David Timms 2016-09-22 09:14:19 UTC
What lines are printed to the terminal during the attempted start when started from a terminal ?

Comment 3 David Timms 2016-09-22 09:35:27 UTC
*** Bug 1361791 has been marked as a duplicate of this bug. ***

Comment 4 Nicolas Dufresne 2016-09-22 13:09:00 UTC
(In reply to David Timms from comment #2)
> What lines are printed to the terminal during the attempted start when
> started from a terminal ?

It's boring, sorry ;-P

$ audacity 
Segmentation fault (core dumped)

Comment 5 Scott Talbert 2016-10-12 03:49:13 UTC
It looks like this happens because audacity dlopen()'s libgnome and libgnomeui, which then call X11 functions.  Those GNOME 2 calls can probably just be patched out because it seems to work fine even if libgnome and libgnomeui packages aren't installed.

Comment 6 Fedora Update System 2016-11-10 12:34:36 UTC
audacity-2.1.3-0.7.20161109git53a5c93.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-99f8d418ba

Comment 7 Fedora Update System 2016-11-10 12:35:46 UTC
audacity-2.1.3-0.7.20161109git53a5c93.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3f35f35613

Comment 8 Fedora Update System 2016-11-10 19:27:56 UTC
audacity-2.1.3-0.7.20161109git53a5c93.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-99f8d418ba

Comment 9 Fedora Update System 2016-11-11 05:02:46 UTC
audacity-2.1.3-0.7.20161109git53a5c93.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3f35f35613

Comment 10 fednuc 2016-11-11 10:27:58 UTC
The new version launches under GNOME Wayland on F25 without the GDK_BACKEND=x11 workaround.

Comment 11 David Timms 2016-11-11 12:37:39 UTC
(In reply to Stephen from comment #10)
> The new version launches under GNOME Wayland on F25 without the
> GDK_BACKEND=x11 workaround.

I wasn't able to trigger the issue, so thanks for testing Stephen.
If you notice any other issues, please create appropriate bugs, thanks.

Comment 12 Fedora Update System 2016-11-24 16:28:12 UTC
audacity-2.1.3-0.7.20161109git53a5c93.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Nicolas Dufresne 2016-11-24 16:59:04 UTC
Thanks, and works for me on F25/GnomeWayland.

Comment 14 Fedora Update System 2016-11-24 20:27:18 UTC
audacity-2.1.3-0.7.20161109git53a5c93.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.