Bug 134645

Summary: 541 memory corruption/panics with raid5
Product: [Fedora] Fedora Reporter: Warren Togami <wtogami>
Component: kernelAssignee: Dave Jones <davej>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 3CC: pfrields, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-09 18:17:57 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 130887    

Description Warren Togami 2004-10-05 08:31:59 EDT
Description of problem:
kernel-2.6.8-1.541 seems to have some kind of memory corruption and
kernel panics when raid5 is in use.  My system has RAID1 for /, RAID1
for swap, and RAID5 for /home, across four disks.

* Booting FC3test2 rescue mode, mounting the /mnt/sysimage raid shows
lots of garbage on the screen.  ls output shows corrupted looking
filenames for anything that is colored.  This is indicative of kernel
induced memory corruption.
* During normal operation running 541, there are random kernel panics.
* Loopback mounting iso images on the raid5 array rapidly causes
kernel panics.

This issue is confirmed solved in 2.6.9-rc2-bk4+

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.541
Comment 1 Warren Togami 2004-10-09 18:17:57 EDT
This seems solved by 590+.