Bug 134715

Summary: Some things that would make gnome terminal better
Product: [Fedora] Fedora Reporter: Daniel Walsh <dwalsh>
Component: gnome-terminalAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED UPSTREAM QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: bclark
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-11-04 00:06:46 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Daniel Walsh 2004-10-05 14:11:32 EDT
1.  Make terminal titles work.   If I say set title to XYZ it should
stay XYZ and not be changing all the time.  
2.  Save previous settings.  IE I would like to have 5 terminals come
up  each with a different title for each machine that I ssh to and one
for root.  (Having the an initial command "ssh" tied to the terminal
would be nice.)
3. Allow me to choose where the tabs go on the terminal.  (Top/Bottom)
Tabs on the bottom make more sence to me since that is where the eye
focuses on a terminal.
4. Allow me to rearrange the terminals on the screen.  So if I create
a new terminal porkchop, I want to move that tab to the first tab.

Alot of these things are present in multi-gnome-terminal, which I used
for a long time.  Now I am trying to use gnome-terminal all the time
but I miss these features.

Dan
Comment 1 Ray Strode [halfline] 2004-10-05 15:02:54 EDT
Hi Dan,

In general it is better to report individual bugs for each issue you have.

1.  This is probably happening because your shell is reseting it.  Try
doing "unset PROMPT_COMMAND" and see if that fixes the problem for you.

If it does then you can probably fix the problem by doing (as root)
touch /etc/sysconfig/bash-prompt-xterm
chmod +x /etc/sysconfig/bash-prompt-xterm

2. gnome-terminal should save this kind of information when you save
your session.  

You should be able to run something like:
    gnome-terminal --command="ssh porkchop.devel.redhat.com"
--title="porkchop" &
    gnome-terminal --command="ssh devserv.devel.redhat.com"
--title="devserv" &
    gnome-terminal --command="ssh mybox.boston.redhat.com" --title="My
Box" &
    gnome-terminal --command="su -" --title="Super User Command Prompt" &
    disown
    exit

You then just need to save your session by either running 
gnome-session-save
or by logging out with the "Save Session" check box checked.

3. This is a decision for the UI designers.

4. Reorderable tabs might be a cool feature.  I think I heard
somewhere that there is a patent issue with doing it, however.
Comment 2 Daniel Walsh 2004-10-05 15:34:48 EDT
I know that it would be better to enter in 5 bug reports, but I was
torn about writing a lot of small bug reports.

1.  That is ok for me to fix, but not really reasonable for a normal
user.  I would figure the default behaviour is if I set at terminal
title it stays the terminal title.  Unsetting PROMPT_COMMAND did stop
the changing.

2. That starts up multiple gnome terminals instead of one with 5 tabs.

3. I meant this for the UI designers.  :^)

4. You got to be kidding me.  :^(

Comment 3 Ray Strode [halfline] 2004-10-05 15:48:36 EDT
You can create alternate profiles with specified titles and commands.
 You can also configure these alternate profiles to not use
dynamically set titles (like those set with PROMPT_COMMAND).
Comment 4 Daniel Walsh 2004-10-05 16:26:24 EDT
That may be, but it is not very user friendly.  How about I just start
up five tabbed terminals, Label them and then press save setup/session
whatever.  Next time I run gnome-terminal it comes up with the five
terminals, already labelled.  Handling the command line would require
more work.

Dan
Comment 5 Bryan W Clark 2004-10-05 16:33:53 EDT
1. The problem could be filed as a bug to gnome-terminal upstream

2. The terminal should be saving all that information in your session.
 A bug should be filed against upstream about this as well.

3. Upstream bug: http://bugzilla.gnome.org/show_bug.cgi?id=75420
   I don't really see why you would need this option.   However I
think it might be reasonably enabled as a context menu off the tabs.

4. Upstream bug: http://bugzilla.gnome.org/show_bug.cgi?id=86938
   This one is a good idea and Epiphany does it well right now.  Code
from there might be able to be taken and used in gnome-terminal
Comment 6 Ray Strode [halfline] 2004-11-04 00:06:46 EST
This bug is being tracked upstream, so closing...