Bug 1347426

Summary: yum-plugin-fastestmirror should be optional
Product: Red Hat Enterprise Linux 7 Reporter: Warren Young <warren>
Component: yumAssignee: Valentina Mukhamedzhanova <vmukhame>
Status: CLOSED NOTABUG QA Contact: BaseOS QE Security Team <qe-baseos-security>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.2CC: james.antill
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-06-17 10:26:05 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Warren Young 2016-06-16 20:11:32 UTC
Description of problem:

The point of plugins is that you can add and remove them without affecting the base app. A mandatory plugin is nonsensical.


Version-Release number of selected component (if applicable):

This has been seen on CentOS 5, 6 and 7.


How reproducible:

$ sudo rpm -e yum-plugin-fastestmirror

(or on EL5, yum-fastestmirror)



Actual results:

error: Failed dependencies:
        yum-plugin-fastestmirror is needed by (installed) yum-3.4.3-132.el7.centos.0.1.noarch


Expected results:

The plugin is uninstalled.


Additional info:

Yes, I realize the plugin can be disabled at run time by editing /etc/yum/pluginconf.d/fastestmirror.conf.  But if someone disables it long-term, why have it installed?

Comment 2 Valentina Mukhamedzhanova 2016-06-17 10:26:05 UTC
This seems to be a CentOS specific packaging issue. Neither upstream yum.spec, nor RHEL yum packages list yum-plugin-fastestmirror as a Requires, so the latter can be easily removed. I'm not sure where this should be reported, maybe try asking around on CentOS forums or IRC.