Bug 1347454

Summary: Enable CONFIG_PWM in x86 kernel builds
Product: [Fedora] Fedora Reporter: Stephen Just <stephenjust>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: rawhideCC: gansalmon, itamar, jonathan, kernel-maint, labbott, madhu.chinakonda, mchehab
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-06-20 19:54:27 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Stephen Just 2016-06-16 23:08:09 UTC
Description of problem:
- Kernel does not build PWM modules on x86 platforms.
- CONFIG_PWM_LPSS is enabled, but it does not automatically cause CONFIG_PWM to be enabled. However, this does suggest that it is intended for CONFIG_PWM to be on.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Compile kernel from src rpm

Actual results:
No PWM modules built

Expected results:
PWM modules built

Additional info:
- An example device that uses PWM_LPSS for backlight is the Microsoft Surface 3.

Comment 1 Laura Abbott 2016-06-20 19:54:27 UTC
Enabled in rawhide. Thanks for reporting.