Bug 1348535

Summary: Overcloud Horizon doesn't load downstream theme
Product: Red Hat OpenStack Reporter: Marius Cornea <mcornea>
Component: python-django-horizonAssignee: Radomir Dopieralski <rdopiera>
Status: CLOSED ERRATA QA Contact: Ido Ovadia <iovadia>
Severity: high Docs Contact:
Priority: unspecified    
Version: 10.0 (Newton)CC: aortega, apannu, athomas, dbecker, jrist, jslagle, mburns, morazi, mrunge, opavlenk, rdopiera, rhel-osp-director-maint, srevivo
Target Milestone: rcKeywords: Triaged
Target Release: 10.0 (Newton)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-django-horizon-10.0.0-0.20160922192235.65dae20.2.el7ost Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-12-14 15:40:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Marius Cornea 2016-06-21 12:06:58 UTC
Description of problem:
Overcloud Horizon doesn't load downstream theme

Version-Release number of selected component (if applicable):
Packages installed in the overcloud image:
openstack-dashboard-10.0.0-0.20160609090113.ce68bf6.el7ost.noarch
puppet-horizon-8.0-0.20160603171336.b7e52d3.el7ost.noarch
python-django-horizon-10.0.0-0.20160609090113.ce68bf6.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud
2. Acess the overcloud Horizon

Actual results:
Horizon doesn't load the downstream theme.

Comment 1 Radomir Dopieralski 2016-09-20 11:58:24 UTC
The downstream theme is in a separate rpm package, openstack-dashboard-theme.

Comment 2 Radomir Dopieralski 2016-09-28 10:31:03 UTC
I can't seem to find any way to add the openstack-dashboard-theme as a dependency in Horizon. I was pointed to https://github.com/openstack/tripleo-puppet-elements as the source of dependencies, but the downstream for that package, https://github.com/redhat-openstack/openstack-puppet-modules/tree/master doesn't seem to be used anymore. I have no more ideas.

Comment 3 Radomir Dopieralski 2016-09-28 11:23:11 UTC
I'm adding the theme as the dependency of the horizon rpm instead. That should fix the issue.

Comment 5 Ido Ovadia 2016-10-06 13:35:45 UTC
Verified
========
puppet-horizon-9.4.0-1.el7ost.noarch
python-django-horizon-10.0.0-0.20161002185148.3252153.1.el7ost.noarch

Comment 6 Ido Ovadia 2016-10-06 13:43:41 UTC
openstack-dashboard-theme-10.0.0-0.20161002185148.3252153.1.el7ost.noarch

Comment 10 errata-xmlrpc 2016-12-14 15:40:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html