Bug 1348717

Summary: [RFE] Add virtio-gpu and spice gl=on support
Product: [oVirt] ovirt-engine Reporter: Badalyan Vyacheslav <v.badalyan>
Component: GeneralAssignee: bugs <bugs>
Status: CLOSED WONTFIX QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: ---CC: bugs, fjin, michal.skrivanek, mtessun, tjelinek
Target Milestone: ---Keywords: FutureFeature
Target Release: ---Flags: michal.skrivanek: ovirt-future?
tjelinek: planning_ack?
tjelinek: devel_ack?
tjelinek: testing_ack?
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-07-06 15:43:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Virt RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Badalyan Vyacheslav 2016-06-21 20:52:19 UTC
Hello!

Please plain to add virtio-gpu and gl=on on spice features to Ovirt. It's very intrasted for VDI support!

Best test case for support android emulator in VM for developers VDI.

RH kvm team was backported support to KVM

https://bugzilla.redhat.com/show_bug.cgi?id=1295907

Thanks!

Comment 1 Michal Skrivanek 2016-07-01 08:37:17 UTC
There are still too many limitations and rough edges to be able to use it for VDI. The client side virgl support is not there yet.

So there is still some work needed before we can add it as a usable feature, we'll review it again once RHEL 7.3 is out to see how stable and usable it is then, so that would likely mean oVirt 4.2 at earliest

Comment 2 Badalyan Vyacheslav 2016-08-14 05:28:57 UTC
http://wiki.qemu.org/ChangeLog/2.6
- SDL2 and SPICE now support OpenGL and virgl. For SPICE, Unix sockets are the only usable transport when OpenGL is enabled.


http://wiki.qemu.org/ChangeLog/2.5
- virtio-gpu 3D support requires virglrenderer.

Comment 3 Martin Tessun 2017-11-17 11:01:33 UTC
(In reply to Badalyan Vyacheslav from comment #2)
> http://wiki.qemu.org/ChangeLog/2.6
> - SDL2 and SPICE now support OpenGL and virgl. For SPICE, Unix sockets are
> the only usable transport when OpenGL is enabled.

Which means you can only use it on a local machine as a Unix Socket cannot be accessed across a network.

We still have quite some work to do here, including vGPU support for NVIDIA Tesla cards, spice-streaming, etc. So this will still take some time to settle.

> 
> 
> http://wiki.qemu.org/ChangeLog/2.5
> - virtio-gpu 3D support requires virglrenderer.

Comment 4 Martin Tessun 2018-07-06 15:43:32 UTC
Due to some security concerns around virGL and vGPU being implemented, closing this one.

The workaround would be to use either vGPU or GPU passthrough for now.

Having VirGL support added will take quite some time until this is meant to be usable enough and including SPICE support.