Bug 1350750

Summary: systemd units for lirc have errors
Product: [Fedora] Fedora Reporter: Chris Warrick <kwpolska>
Component: lircAssignee: Alec Leamas <leamas.alec>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 24CC: bnocera, fedora, jarodwilson, leamas.alec
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: lirc-0.9.4a-1.fc24 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-02 15:24:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
systemd lirc unit bugs none

Description Chris Warrick 2016-06-28 09:40:05 UTC
Created attachment 1173355 [details]
systemd lirc unit bugs

Description of problem:
systemd units for those units contain bugs that are not parsed correctly. Example:

Documentation=System daemon handling events from IR remotes decoded \
by lircd
;; broken into multiple lines, seemingly unsupported
[Service]
; user =
: group =
;; first line is semicolon, second line is colon
Type=simple
ExecStart=/usr/sbin/irexec /etc/lirc/irexec.lircrc

Version-Release number of selected component (if applicable):
lirc-core-0.9.4-3.fc24.x86_64
systemd-229-8.fc24.x86_64

How reproducible:
always

Steps to Reproduce:
1. reload systemd units
2. wait a while
3. check journalctl

Actual results:
errors (see attachment)

Expected results:
correct load

Additional info:

Comment 1 Alec Leamas 2016-06-28 10:18:32 UTC
Hm... what's happening here?

- When I download a fresh lirc-core package using "dnf --releasever=24 download lirc-core" the downloaded lircd.service file is correctly commented with semicolons, not comma in both cases.
- Line continuation using \ is specified in the systemd.unit(5) manpage (and has been working well since long). Have you trailing whitespace after the  backslash.

Or, have you your own copies in /etc/systemd/system overriding the system defaults?

Comment 2 Chris Warrick 2016-06-28 10:30:32 UTC
irexec.service has the colon bug, and I can’t see trailing whitespace anywhere. Original copies.

Comment 3 Alec Leamas 2016-06-28 10:45:00 UTC
> irexec.service has the colon bug,

Indeed. Will fix.

>  I can’t see trailing whitespace anywhere.

Still, line continuation using \ is supported... What is the exact error you get?

Comment 4 Alec Leamas 2016-06-28 10:49:11 UTC
Ah... Documentation=  only allows URI:s, not free text. Need to fix this as well. Will update today or possibly tomorrow. I presume you can work around this for the moment.

Comment 5 Chris Warrick 2016-06-28 11:30:02 UTC
(I worked around it by removing lirc, which is completely unnecessary on a server. Located 1000+ km away from me. And in case you hadn’t noticed, there’s an attachment with all errors.)

Comment 6 Fedora Update System 2016-06-29 20:56:40 UTC
lirc-0.9.4a-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-90909780cf

Comment 7 Fedora Update System 2016-06-30 22:26:28 UTC
lirc-0.9.4a-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-90909780cf

Comment 8 Fedora Update System 2016-07-02 15:24:28 UTC
lirc-0.9.4a-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.