Bug 135082

Summary: xserver freezes machine after updates
Product: [Fedora] Fedora Reporter: Tielman de Villiers <tvilliers>
Component: xorg-x11Assignee: Mike A. Harris <mharris>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: high Docs Contact:
Priority: medium    
Version: 3CC: adrian, davej, harald, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-13 07:23:18 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 130887    

Description Tielman de Villiers 2004-10-08 11:03:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0)

Description of problem:
I ran 
yum -y update yum
yum -y update open*
yum -y update g*
yum -y update b* c* d* e* f*
yum -y update h* i* j* k* l*
yum -y update m* n* o* p* udev selinux-policy-targetted
yum -y update x*

and when then try to startx, it freezes the machine completely with a 
blank black screen. Nothing will unluck it, except a hard reboot. The 
problem starts before that, though. Before the second last 
update "Starting udev" was the first startup message. Now it's gone. 
Also, there are poblems with mDNSresponder services:
/etc/profile.d/colorls.sh /dev/null permission denied.
and when I try to log in as a user I get:
-bash /dev/null permission denied

when I do ls -l /dev/null, it shows 
crw------- 
which should be 
crw-rw-rw-

Even if i try to startx as root, the machine freezes

Version-Release number of selected component (if applicable):
xorg-x11-*-6.8.1-4

How reproducible:
Always

Steps to Reproduce:
1. install as desktop, withou firewall and selinux 
2. change /etc/inittab to level 3
3. update packages as above
4. startx
    

Actual Results:  frozen black screen

Expected Results:  a gui

Additional info:
Comment 1 Adrian Reber 2004-10-12 14:30:35 EDT
The same happens to me, the machine completely freezes if I try to
init 5 or startx. I have no additional information. No logs are available.

xorg-x11-6.8.1-4
kernel-2.6.8-1.541

01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro
AGP 1X/2X (rev 5c)

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 6
cpu MHz         : 804.046
cache size      : 256 KB
Comment 3 Mike A. Harris 2004-10-12 18:05:01 EDT
If /dev/null has incorrect permissions, it would seem that there
is a bigger problem at hand.  This may be a udev or kernel bug
rather than an X server bug.

I've CC'd a couple of our kernel developers, and our udev package
maintainer for comment.

Dave/Arjan/Harald - any comments on this one?
Comment 5 Harald Hoyer 2004-10-13 04:53:30 EDT
which version of udev? is the system started with an initrd?
does 
# mkinitrd -f /boot/initrd-$(uname -r).img $(uname -r)
help?
is SELINUX activated?
Comment 6 Harald Hoyer 2004-10-13 05:06:31 EDT
> "Starting udev" was the first startup message. Now it's gone.
This is the cause of your problems..
Comment 7 Tielman de Villiers 2004-10-13 05:20:26 EDT
I have updated all my rpms with yum this morning, and the problem
seems to be solved. It did indeed seem like a udev (rather than a
xorg-x11) problem. For the record, my udev version is now udev-034-2.
mkinitrd -f /boot/initrd-$(uname -r).img $(uname -r) gave me this in
/boot: initrd-2.6.8-1.541.img
SELINUX was specifically "deactivated" during install, and has still
not been activated.
Comment 8 Mike A. Harris 2004-10-13 07:23:18 EDT
Ok, thanks for the update Thielman.  It appears this was just
a temporary udev glitch.

Setting status to "RAWHIDE"