Bug 135134

Summary: rhgb + agp i915 hangs kernel-2.6.8.1-603smp boot on dual P3 system
Product: [Fedora] Fedora Reporter: Jason Vas Dias <jvdias>
Component: kernelAssignee: Dave Jones <davej>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: pfrields, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: kernel-2.6.9-1.639 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-20 17:59:59 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 130887    

Description Jason Vas Dias 2004-10-08 17:33:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
kernel-2.6.8.1-603smp fails to boot at all with with the 'rhgb'
boot option on a dual P3 processor system. It boots fine without the 
rhgb option, and the non-smp kernel boots fine on a different
uniprocessor system.

I don't know if this is a kernel problem or an rhgb problem;
but as the kernel boots OK without the 'rhgb' boot option,
I'm raising it as a rhgb bug.

I'm not sure how to gather more debug information on this;
with the rhgb option, the smp kernel doesn't boot at all -
I've tracked it down to where it sets the clock in rc.sysinit,
around line 234, after the 'action ... sysctl', in 
   'update_boot_stage RCclock'

If I enable the sysrq=1 sysctl option in sysctl.conf, change to
VT1 when the boot hangs, and press sysrq, I get this message on
the console:

/etc/init.d/functions: line 428: /etc/rhgb/temp/rhgb-console:
Interrupted system call 

and the system hangs, never booting nor responding to any boot
key sequence (like ctrl+alt+del) - so I have to power-off and 
remove the 'rhgb' option or supply the '-s' option in order to boot.

This happens both with and without selinux enabled, with all RPMS
updated to rawhide-20041008 . 

The system has 2 x 2.8GHz P3s (model 3) with an Intel 915G video card.





Version-Release number of selected component (if applicable):
rhgb-0.13.5-2

How reproducible:
Always

Steps to Reproduce:
1. Boot kernel-2.6.8-1.603smp on a dual processor system with rhgb 
   option

    

Actual Results:  System never boots

Expected Results:  System should boot OK.

Additional info:
Comment 1 Dave Jones 2004-10-08 17:43:54 EDT
did -598 work ?
Does booting with agp=off help ? (i915 agp driver changed recently)

with rhgb disabled, does it boot into runlevel 5 and startx ok ?
Comment 2 Jason Vas Dias 2004-10-08 17:51:51 EDT
Yes, it booted -598 fine. 

As the previous comment states, -603 boots fine without the 'rhgb'
boot option.

Aha! I just found out: with the agp=off option, it boots fine in
graphical mode too.

It looks like this is a kernel (i915 agp driver) problem . I'll move
it to the kernel.
Comment 3 Kevin Fries 2004-10-09 01:04:49 EDT
I am still having to boot kernel 541 because both 598 and 603 have
both failed to boot the non smp kernel.  It gets to the point where it
goes to the graphical boot (which I actually dispise, how do I get it
to stop and show me the OKs) then simply goes black.  Ctl-Alt-Del does
not reboot, no activity (hard drive, etc).

Hardware: Intel 865 PE50, using onboard video
Comment 4 Kevin Fries 2004-10-09 15:24:47 EDT
Today I did an rpm -e on rhgb and all is right with the world again. 
Not only do I have 603 booting, I don't have that awful Microsoftish
boot up.  My reassuring OK's are now gracing my screen.... ahhhhhhhhh

So, it appears that there must be some type of incompatability between
the graphical boot system and Intel video cards.

Good Luck
Comment 5 Jason Vas Dias 2004-10-11 19:05:51 EDT
This bug could be related to bug #132267 - more problems with
Intel video cards and X .
Comment 6 Mike A. Harris 2004-10-13 14:56:17 EDT
It probably is the same bug, caused by rhgb starting 2 X servers
simultaneously which wont work on Intel video hardware.
Comment 7 Kristian Høgsberg 2004-10-17 16:19:17 EDT
I've reproduced the problem on an i830 chipset, but upgrading to the
-610 kernel solves the problem for me.  Could you try to update to
-610 (it's probably best to avoid -624) and see if it also solves your
problem?

Thanks.
Comment 8 Jason Vas Dias 2004-10-20 17:59:59 EDT
This is now fixed in kernel-2.6.9-1.639+ .