Bug 1352396

Summary: [UPGRADE]: Radosgw process doesn't start after the upgrade from 1.3.2 to 2.0 with parameter "setuser match path = /var/lib/ceph/$type/$cluster-$id"
Product: Red Hat Ceph Storage Reporter: shylesh <shmohan>
Component: RGWAssignee: Orit Wasserman <owasserm>
Status: CLOSED ERRATA QA Contact: shylesh <shmohan>
Severity: high Docs Contact:
Priority: unspecified    
Version: 2.0CC: cbodley, ceph-eng-bugs, ceph-qe-bugs, hnallurv, kbader, kdreyer, mbenjamin, owasserm, sweil
Target Milestone: rc   
Target Release: 2.0   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: RHEL: ceph-10.2.2-21.el7cp Ubuntu: ceph_10.2.2-16redhat1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-23 19:43:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 6 Ken Dreyer (Red Hat) 2016-07-12 18:11:17 UTC
Discussed this in RGW bug scrub today. Casey and Yehuda think it might be fixed with https://github.com/ceph/ceph/commit/dfb897ad576e4861a3cb75d85dffbbeaad5e980e

Comment 13 Harish NV Rao 2016-07-13 06:20:51 UTC
resetting need_info as shylesh provided the ack.

Comment 14 shylesh 2016-07-19 06:33:41 UTC
Verified on 10.2.2-21

Comment 16 errata-xmlrpc 2016-08-23 19:43:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html