Bug 1353688

Summary: Fedora Atomic Image: user-uid.journal doesn't exist at all on first boot
Product: [Fedora] Fedora Reporter: Trishna Guha <trishnaguha17>
Component: rpm-ostreeAssignee: Colin Walters <walters>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 24CC: adimania, amurdaca, dustymabe, dwalsh, lsm5, mail, mattdm, trishnaguha17, walters
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-09-14 17:06:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Trishna Guha 2016-07-07 17:42:17 UTC
Description of problem:

user-uid.journal is not getting written to disk on first boot of atomic images.
We have seen this for Fedora23 and Fedora24 atomic images.

Though system.journal is getting written /run(It should be /var instead: we have separate issue for this: https://bugzilla.redhat.com/show_bug.cgi?id=1265295), but user-uid.journal is getting completely ignored. So user-uid.journal doesn't exist at all on first boot.


##### FIRST BOOT ######

# ls -l /proc/614/fd/ | grep journal
lrwx------. 1 root root 64 Jul  7 17:28 16 -> /run/log/journal/6eaae11473d042169d8938bbf1142557/system.journal

###### 1st REBOOT #########

# ls -l /proc/614/fd/ | grep journal
lrwx------. 1 root root 64 Jul  7 17:32 18 -> /var/log/journal/6eaae11473d042169d8938bbf1142557/system.journal
lrwx------. 1 root root 64 Jul  7 17:32 29 -> /var/log/journal/6eaae11473d042169d8938bbf1142557/user-1000.journal


How reproducible:
Always

Steps to Reproduce:
See Description

Actual results:
See Description

Expected results:

##### FIRST BOOT ######

# ls -l /proc/614/fd/ | grep journal
lrwx------. 1 root root 64 Jul  7 17:32 18 -> /var/log/journal/6eaae11473d042169d8938bbf1142557/system.journal
lrwx------. 1 root root 64 Jul  7 17:32 29 -> /var/log/journal/6eaae11473d042169d8938bbf1142557/user-1000.journal


###### 1st REBOOT #########

# ls -l /proc/614/fd/ | grep journal
lrwx------. 1 root root 64 Jul  7 17:32 18 -> /var/log/journal/6eaae11473d042169d8938bbf1142557/system.journal
lrwx------. 1 root root 64 Jul  7 17:32 29 -> /var/log/journal/6eaae11473d042169d8938bbf1142557/user-1000.journal

Comment 2 Colin Walters 2016-08-31 17:33:28 UTC
I suspect this is at least related to https://bugzilla.redhat.com/show_bug.cgi?id=1265295

Will try to look at that today.

Comment 3 Colin Walters 2016-09-11 17:47:00 UTC
This works for me after

https://pagure.io/fedora-atomic/c/9c4b3cb0e437de9af14d7134a58c5caf04eaa308?branch=f24

Upgrading today:

‚óŹ fedora-atomic:fedora-atomic/24/x86_64/docker-host
       Version: 24.39 (2016-09-10 20:20:09)
        Commit: 2b9190430e1cdd50e08edd0d478924f118c9a25bdbdbbef6b8b855d480316da2
        OSName: fedora-atomic

Comment 4 Colin Walters 2016-09-14 17:06:07 UTC
This is basically the same as 1265295.

*** This bug has been marked as a duplicate of bug 1265295 ***