Bug 135422

Summary: getent returns nothing
Product: Red Hat Enterprise Linux 3 Reporter: Roehl Obaldo <robaldo>
Component: glibcAssignee: Jakub Jelinek <jakub>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 3.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-22 03:42:03 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Roehl Obaldo 2004-10-12 12:55:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
Getent hosts will not display output if hostname starts with numeric.
It has no problem resolving if hostname starts with alpha characters.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Configure hosts entry in /etc/nsswitch.conf to first look 
in /etc/hosts.
2.Add two entries to the /etc/hosts file:    dhcp2-1    2dhcp2
3.Issue the commands:
getent hosts dhcp2-1
getent hosts 2dhcp2


Actual Results:  getent hosts dhcp2-1     dhcp2-1

getent hosts 2dhcp2

Expected Results:  getent hosts dhcp2-1     dhcp2-1

getent hosts 2dhcp2    2dhcp2

Additional info:
Comment 1 Jakub Jelinek 2004-10-22 03:42:03 EDT
Fixed in glibc-2.3.3-73.