Bug 1361338

Summary: Connecting to /dev/log gets Connection Refused
Product: [Fedora] Fedora Reporter: Mairi Dulaney <jdulaney>
Component: systemdAssignee: systemd-maint
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: awilliam, gmarr, jdulaney, johannbg, lnykryn, msekleta, muadda, robatino, ssahani, s, systemd-maint, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-09 16:59:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1277284    

Description Mairi Dulaney 2016-07-28 21:04:10 UTC
Description of problem:
Connecting to /dev/log, at least via Python/Python3 results in a ConnectionRefusedError

This prevents Anaconda from running, and thus I'll be nominating this bug as a blocker bug.

An easy way to reproduce is to run the following two lines in the python interpreter:

import logging.handlers
handler = logging.handlers.SysLogHandler(address = '/dev/log')

The permissions on /run/systemd/journal/dev-log are srw-rw-rw-.

Version-Release number of selected component (if applicable):
systemd 231-1.fc25.x86_64

How reproducible:

Steps to Reproduce:
1.  Boot system
2.  Open terminal
3.  Run python or python3
4.  Type in the previously mentioned code

Actual results:
/dev/log is not writable

Expected results:
/dev/log is writable

Additional info:

Nominating as a blocker bug as this clearly prevents installation.

Comment 1 Fedora Blocker Bugs Application 2016-07-28 21:07:38 UTC
Proposed as a Blocker for 25-alpha by Fedora user jdulaney using the blocker tracking app because:

 The installer must run when launched normally from the release-blocking images.

Comment 2 Mairi Dulaney 2016-07-28 21:11:19 UTC
Also attempted this with enforcing set to permissive, with the same result.

Comment 3 Zbigniew Jędrzejewski-Szmek 2016-07-29 02:47:09 UTC
ConnectionRefused is thrown when the socket has been closed by the listener. For example, if systemd-journald was stopped, then this result would be expected. But normally journald is immediately restarted, even if it stops. So something special must be going on here...

In what situation did you see the error? Running from the installation dvd, or from an installed system? Can you attach the logs?

Comment 4 Mairi Dulaney 2016-07-29 02:52:24 UTC
LiveCD booted in a vm, will attach logs shortly.

Comment 5 Zbigniew Jędrzejewski-Szmek 2016-07-29 04:59:31 UTC
Which CD image?

Comment 6 Mairi Dulaney 2016-08-02 21:35:52 UTC
Okay, I see nothing interesting in the logs.  This is with the XFCE image.  I'm going to try to reproduce with a newer image.

Comment 7 Adam Williamson 2016-08-08 16:15:12 UTC
I just tried this in both a BIOS KVM and a UEFI KVM with Fedora-Workstation-Live-x86_64-25-20160805.n.0.iso and could not reproduce it. anaconda launches fine and the given python code runs without error.

Comment 8 Geoffrey Marr 2016-08-08 17:32:17 UTC
Discussed during the 2016-08-08 blocker review meeting: [1]

The decision was made to delay the classification of this as a bug, as no one in the blocker-review meeting had experienced the bug and as such, more information and testing are required before this can be appropriately classified.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-08-08/f25-blocker-review.2016-08-08-16.01.txt

Comment 9 Zbigniew Jędrzejewski-Szmek 2016-08-09 16:59:22 UTC
The reproducer from #c0 works fine with Fedora-Xfce-Live-i386-25-20160809.n.0.iso. I think it must have been just a bleep on the radar, please reopen if you can reproduce.

Comment 10 Mairi Dulaney 2016-08-10 18:37:34 UTC
Yeah, I cannot reproduce with new images.