Bug 1367892

Summary: appstream vala / vapi bindings not packaged
Product: [Fedora] Fedora Reporter: Fabio Valentini <decathorpe>
Component: appstreamAssignee: Rex Dieter <rdieter>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 24CC: rdieter
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: appstream-0.9.8-3.fc24 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-29 18:54:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Fabio Valentini 2016-08-17 17:49:34 UTC
Description of problem:

appstream-vala package should contain the vapi file as per the RPM spec, but that package is not built (perhaps because it is obsoleted by appstream?), so the vapi file is not available on fedora _at all_.



Version-Release number of selected component (if applicable):

0.9.6


$ sudo dnf provides '/usr/share/vala/vapi/appstream.vapi'
  Error: No Matches found

Comment 1 Rex Dieter 2016-08-17 17:59:55 UTC
I disabled building it because, well, it didn't build at one point, and nothing in fedora actually used them.   Maybe it works now, I can try and let you know.

Comment 2 Rex Dieter 2016-08-18 15:39:07 UTC
(Still) failing mysteriously on f25/arm,

Scanning dependencies of target as-test-xmldata
make[2]: Leaving directory '/builddir/build/BUILD/AppStream-0.9.8/armv7hl-redhat-linux-gnueabi'
make -f tests/CMakeFiles/as-test-xmldata.dir/build.make tests/CMakeFiles/as-test-xmldata.dir/build
[ 90%] Generating AppStream-1.0.typelib
cd /builddir/build/BUILD/AppStream-0.9.8/src && /usr/bin/g-ir-compiler --includedir=/builddir/build/BUILD/AppStream-0.9.8/src --includedir=. /builddir/build/BUILD/AppStream-0.9.8/armv7hl-redhat-linux-gnueabi/src/AppStream-1.0.gir -o /builddir/build/BUILD/AppStream-0.9.8/armv7hl-redhat-linux-gnueabi/src/AppStream-1.0.typelib
error parsing file /builddir/build/BUILD/AppStream-0.9.8/armv7hl-redhat-linux-gnueabi/src/AppStream-1.0.gir: Error on line 632 char 64: Document ended unexpectedly with elements still open - 'doc' was the last element opened
src/CMakeFiles/gir-typelibs.dir/build.make:63: recipe for target 'src/AppStream-1.0.typelib' failed
make[2]: Leaving directory '/builddir/build/BUILD/AppStream-0.9.8/armv7hl-redhat-linux-gnueabi'
CMakeFiles/Makefile2:198: recipe for target 'src/CMakeFiles/gir-typelibs.dir/all' failed
make[2]: *** [src/AppStream-1.0.typelib] Error 1
make[1]: *** [src/CMakeFiles/gir-typelibs.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....

Comment 3 Rex Dieter 2016-08-18 15:39:40 UTC
Full build/logs, etc:
https://koji.fedoraproject.org/koji/taskinfo?taskID=15288380

Comment 4 Fedora Update System 2016-08-18 18:27:03 UTC
appstream-0.9.8-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d3de5c7e1e

Comment 5 Fabio Valentini 2016-08-18 20:36:03 UTC
That f25/arm build failure looks weird, yes. Like somehow, the produced XML file is not valid XML ...

Looking at the logs, it seems the g-ir-scanner invocation for generating the .gir file is ran TWICE in parallel (build.log lines 554,555,556,557) with the same output file, maybe that screws the file up?

It may be a race condition in the parallel build (CMake makes g-ir-scanner run twice? why?) that only happens on arm, because even though the exact same g-ir-scanner command is run twice on every platform, e.g. x86_64 the command is executed one after the other - not so on arm, it seems.

But honestly, I'm just guessing there ;-)

But my problem (this bug) seems to be fixed either way, just waiting for the build to hit updates-testing. Thanks!

Comment 6 Fedora Update System 2016-08-19 23:21:52 UTC
appstream-0.9.8-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d3de5c7e1e

Comment 7 Fedora Update System 2016-08-29 18:54:45 UTC
appstream-0.9.8-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.