Bug 1368024

Summary: [extras-rhel-7.2.7] Docker should avoid blob re-uploads
Product: Red Hat Enterprise Linux 7 Reporter: Michal Minar <miminar>
Component: dockerAssignee: Daniel Walsh <dwalsh>
Status: CLOSED ERRATA QA Contact: Mike Fiedler <mifiedle>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 7.2CC: agladkov, aos-bugs, cewong, jokerman, lsm5, lsu, mfojtik, mifiedle, mmccomas, sdodson, tdawson, vlaad, wmeng, wsun, xtian
Target Milestone: rcKeywords: Extras, TestBlocker
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: docker-1.10.3-46.el7.11.x86_64 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1358536 Environment:
Last Closed: 2016-09-15 08:30:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1358536    

Comment 1 Michal Minar 2016-08-18 07:18:01 UTC
To summarize, we'd like Docker, during a push of blob, to:

1. It could try to mount from each remembered association before falling back to full blob upload.
2. Verify if the blob really doesn't exist in the source repository before forgetting its association.
3. Stat() the target repository even if there's no remembered association between blob and the destination repository.

Comment 2 Michal Minar 2016-08-18 15:10:27 UTC
Partial and simple solution is at https://github.com/projectatomic/docker/pull/183

We should propose a more thorough implementation covering comment 1 before submitting upstream though.

Comment 3 Lokesh Mandvekar 2016-08-20 09:45:23 UTC
Moving bug to docker..

Comment 4 Daniel Walsh 2016-08-20 09:52:45 UTC
Michal should we have this patch in docker-1.12 also?

Comment 8 Mike Fiedler 2016-08-23 12:37:10 UTC
Lokesh,  Where can we pick up the new build?   The latest version on the Openshift QE mirror is 	docker-1.10.3-46.el7.10.x86_64

Comment 10 Mike Fiedler 2016-08-23 17:11:36 UTC
Provided sdodson with URL, but documenting here, too:

https://mirror.openshift.com/enterprise/rhel/dockerextra/x86_64/os/

Comment 16 errata-xmlrpc 2016-09-15 08:30:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1827.html