Bug 1369328

Summary: [RFE] Add a count of snapshots associated with a volume to the output of the vol info command
Product: [Community] GlusterFS Reporter: Avra Sengupta <asengupt>
Component: snapshotAssignee: Avra Sengupta <asengupt>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 3.8CC: asengupt, bugs, pcuzner, rjoseph
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: glusterfs-3.8.4 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1360693 Environment:
Last Closed: 2016-09-16 18:28:22 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1129468, 1360693    
Bug Blocks: 1369326    

Comment 1 Worker Ant 2016-08-23 07:16:32 UTC
REVIEW: http://review.gluster.org/15288 (snapshot: Display number of snapshots in volume info) posted (#1) for review on release-3.8 by Avra Sengupta (asengupt@redhat.com)

Comment 2 Worker Ant 2016-08-24 10:17:35 UTC
COMMIT: http://review.gluster.org/15288 committed in release-3.8 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 5d833c89aacc747d0bc654b4ab947c6bf59366d0
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Wed Jul 27 16:28:44 2016 +0530

    snapshot: Display number of snapshots in volume info
    
        Backport of http://review.gluster.org/#/c/15029/
    
    Display number of snapshots in a volume in volume info
    output. This number gets modified, with create, delete,
    and restore operations.
    
    > Reviewed-on: http://review.gluster.org/15029
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    
    (cherry picked from commit 1df4a89de17e44c8c1f9b4794a7b8c2741f2bc2e)
    
    Change-Id: Ic9b7c2b6950980f8ce75ca362998c097ea7c863d
    BUG: 1369328
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/15288
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>

Comment 3 Niels de Vos 2016-09-12 05:37:12 UTC
All 3.8.x bugs are now reported against version 3.8 (without .x). For more information, see http://www.gluster.org/pipermail/gluster-devel/2016-September/050859.html

Comment 4 Niels de Vos 2016-09-16 18:28:22 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.4, please open a new bug report.

glusterfs-3.8.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/announce/2016-September/000060.html
[2] https://www.gluster.org/pipermail/gluster-users/