Bug 1370134

Summary: Several ipa-* packages conflict with themself
Product: Red Hat Enterprise Linux 7 Reporter: Marian Ganisin <mganisin>
Component: yumAssignee: Michal Domonkos <mdomonko>
Status: CLOSED ERRATA QA Contact: Eva Mrakova <emrakova>
Severity: high Docs Contact: Aneta Šteflová Petrová <apetrova>
Priority: high    
Version: 7.3CC: ableisch, alhilaly_a, alvin, anazmy, aparsons, arusso, asakpal, aschorr, bloch, brcoca, c.handel, derli, divi, dkelson, dshaw, edg, emrakova, hajek, ian, isleno, james.antill, jay.hilliard, jbastian, jpazdziora, knweiss, kwalker, marcbuigues, mbasti, mbliss, mcepl, mdomonko, michael.vandeborne, mkutlak, mscherer, negativo17, paulds, paygupta, philwyett.hemisphere, pvoborni, rcritten, redhat, ricardo.arguello, system-messages, tgummels, tom, tru, vcojot, vijsingh, vmukhame, woodard, yann.lopez, zmaples
Target Milestone: rcKeywords: Patch
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: yum-3.4.3-154.el7 Doc Type: Release Note
Doc Text:
*yum* no longer reports package conflicts after installing _ipa-client_ After the user installed the _ipa-client_ package, the *yum* utility unexpectedly reported package conflicts between the _ipa_ and _freeipa_ packages. These errors occurred after failed transactions or after using the "yum check" command. With this update, *yum* no longer reports errors about self-conflicting packages because such conflicts are allowed by RPM. As a result, *yum* no longer displays the described errors after installing _ipa-client_.
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-08-01 09:07:52 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1256306, 1380360, 1393866, 1446211, 1381646    

Description Marian Ganisin 2016-08-25 11:56:59 UTC
Description of problem:

Historically couple of packages seem to conflict with freeipa counterparts on purpose:

$ rpm -qp --conflicts ipa-client-4.4.0-7.el7.x86_64.rpm 
freeipa-client

However new version included in RHEL-7.3 introduced new rpm provides:

$ rpm -qp --provides ipa-client-4.4.0-7.el7.x86_64.rpm 
freeipa-client = 4.4.0
ipa-client = 4.4.0-7.el7
ipa-client(x86-64) = 4.4.0-7.el7

Due to that a curious state occurred which resulted in ipa-client conflicting with itself (and all other packages that have this provides & conflicts pair implemented)

This seems to break _neither_ installation _nor_ update. From that  point of view everything seems to be fine.

However having package conflicting with itself looks unusual.

Furthermore 'yum check' command exits with non-zero (1) status code and produces following output:

$ yum check
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Error: check all
ipa-client-4.4.0-7.el7.x86_64 has installed conflicts freeipa-client: ipa-client-4.4.0-7.el7.x86_64
ipa-client-common-4.4.0-7.el7.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.4.0-7.el7.noarch
ipa-common-4.4.0-7.el7.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-7.el7.noarch
ipa-python-compat-4.4.0-7.el7.noarch has installed conflicts freeipa-python-compat: ipa-python-compat-4.4.0-7.el7.noarch



Version-Release number of selected component (if applicable):
4.4.0-7

How reproducible:
always

Steps to Reproduce:
1. install ipa-client (and/or others)
2. run yum check


Actual results:
Packages conflicting with itself present
yum check broken! it always reports errors despite to fact everything seems to be fine

Expected results:
Possibly no packages conflicting with itself
functional yum check

Comment 2 Martin Bašti 2016-08-31 13:31:44 UTC
Hello yum team, can you please check if this is bug on yum side? It works as expected, there is only one issue with `yum check`

Provides were added here https://bugzilla.redhat.com/show_bug.cgi?id=1264503

Comment 3 Valentina Mukhamedzhanova 2016-09-20 13:56:58 UTC
Thank you, we should fix yum check.

Comment 10 Petr Vobornik 2016-11-16 19:32:09 UTC
*** Bug 1393311 has been marked as a duplicate of this bug. ***

Comment 11 Jeff Bastian 2016-11-16 19:37:00 UTC
(In reply to Valentina Mukhamedzhanova from comment #3)
> Thank you, we should fix yum check.

Will fixing yum check also fix package-cleanup?

$ package-cleanup --problems
Loaded plugins: auto-update-debuginfo, etckeeper, langpacks, product-id
Package ipa-client-4.4.0-12.el7.x86_64 has installed conflicts freeipa-client: ipa-client-4.4.0-12.el7.x86_64
Package ipa-client-common-4.4.0-12.el7.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.4.0-12.el7.noarch
Package ipa-common-4.4.0-12.el7.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-12.el7.noarch
Package ipa-python-compat-4.4.0-12.el7.noarch has installed conflicts freeipa-python-compat: ipa-python-compat-4.4.0-12.el7.noarch

Comment 12 Jeff Bastian 2016-11-16 19:38:59 UTC
*** Bug 1395830 has been marked as a duplicate of this bug. ***

Comment 15 Futur Fusionneur 2017-02-05 14:14:45 UTC
Problem still present 

[root@hostname]# yum check
Loaded plugins: fastestmirror, langpacks
ipa-client-4.4.0-14.el7.centos.4.x86_64 has installed conflicts freeipa-client: ipa-client-4.4.0-14.el7.centos.4.x86_64
ipa-client-common-4.4.0-14.el7.centos.4.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.4.0-14.el7.centos.4.noarch
ipa-common-4.4.0-14.el7.centos.4.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-14.el7.centos.4.noarch
ipa-python-compat-4.4.0-14.el7.centos.4.noarch has installed conflicts freeipa-python-compat: ipa-python-compat-4.4.0-14.el7.centos.4.noarch
Error: check all

Comment 16 Martin Kutlak 2017-02-08 09:41:59 UTC
The problem is still present.

** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
ipa-client-4.4.0-12.el7.x86_64 has installed conflicts freeipa-client: ipa-client-4.4.0-12.el7.x86_64
ipa-client-common-4.4.0-12.el7.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.4.0-12.el7.noarch
ipa-common-4.4.0-12.el7.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-12.el7.noarch

Comment 17 Dax Kelson 2017-02-27 17:53:53 UTC
Until this gets fixed for real, I'm using this temporary workaround in our training VMs (which only live for a week at a time).

sed -i "/for creq in pkg.conflicts:/a\                if creq[0].startswith('freeipa'): continue" /usr/lib/python2.7/site-packages/yum/rpmsack.py

Comment 20 Paul Stauffer 2017-03-09 09:53:00 UTC
FWIW, another (3rd party) affected package is nvidia-kmod from Nvidia's cuda repo:

Package 1:nvidia-kmod-367.48-2.el7.x86_64 has installed conflicts nvidia-uvm-kmod: 1:nvidia-kmod-367.48-2.el7.x86_64

$ rpm -q --conflicts nvidia-kmod-367.48-2.el7
nvidia-uvm-kmod
$ rpm -q --provides nvidia-kmod-367.48-2.el7
nvidia-kmod = 1:367.48-2.el7
nvidia-kmod(x86-64) = 1:367.48-2.el7
nvidia-uvm-kmod = 367.48-2.el7

Thought I'd note this here to assist anyone else searching for an explanation of this problem as related to that package.

Comment 21 Michal Domonkos 2017-03-09 10:09:41 UTC
(In reply to Paul Stauffer from comment #20)
> FWIW, another (3rd party) affected package is nvidia-kmod from Nvidia's cuda
> repo:
> 
> Package 1:nvidia-kmod-367.48-2.el7.x86_64 has installed conflicts
> nvidia-uvm-kmod: 1:nvidia-kmod-367.48-2.el7.x86_64
> 
> $ rpm -q --conflicts nvidia-kmod-367.48-2.el7
> nvidia-uvm-kmod
> $ rpm -q --provides nvidia-kmod-367.48-2.el7
> nvidia-kmod = 1:367.48-2.el7
> nvidia-kmod(x86-64) = 1:367.48-2.el7
> nvidia-uvm-kmod = 367.48-2.el7
> 
> Thought I'd note this here to assist anyone else searching for an
> explanation of this problem as related to that package.

Thank you!  We have already identified the problem and it turns out it has been fixed upstream in the past:

commit 1ff69afbb78e9303a0d9859d941371eaedbb6842
Author: James Antill <james@and.org>
Date:   Mon Sep 22 16:22:42 2014 -0400

    Have "yum check" ignore self conflicts.

We're going to include the patch in the next minor release of RHEL.

Comment 22 Futur Fusionneur 2017-03-12 14:27:28 UTC
Still here:
ipa-common-4.4.0-14.el7.centos.6.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-14.el7.centos.6.noarch
ipa-python-compat-4.4.0-14.el7.centos.6.noarch has installed conflicts freeipa-python-compat: ipa-python-compat-4.4.0-14.el7.centos.6.noarch

Comment 23 GLS 2017-03-15 11:05:44 UTC
Still wrong, (SO updated to 7-3.1611)

ipa-client-4.4.0-14.el7.centos.6.x86_64 has installed conflicts freeipa-client: ipa-client-4.4.0-14.el7.centos.6.x86_64
ipa-client-common-4.4.0-14.el7.centos.6.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.4.0-14.el7.centos.6.noarch
ipa-common-4.4.0-14.el7.centos.6.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-14.el7.centos.6.noarch
ipa-python-compat-4.4.0-14.el7.centos.6.noarch has installed conflicts freeipa-python-compat: ipa-python-compat-4.4.0-14.el7.centos.6.noarch

Comment 24 Michaël Van de Borne 2017-03-20 21:03:03 UTC
Although this error might not seem blocking, it completely blocks the upgrade of a large hadoop cluster, since Ambari won't install anything if this check does not pass. May you have any workaround so that the error code returned would be 0?

Comment 25 Dax Kelson 2017-03-20 21:56:04 UTC
(In reply to Michaël Van de Borne from comment #24)
> Although this error might not seem blocking, it completely blocks the
> upgrade of a large hadoop cluster, since Ambari won't install anything if
> this check does not pass. May you have any workaround so that the error code
> returned would be 0?

See comment #17

Comment 26 Michaël Van de Borne 2017-03-20 22:30:31 UTC
(In reply to Dax Kelson from comment #25)
> (In reply to Michaël Van de Borne from comment #24)
> > Although this error might not seem blocking, it completely blocks the
> > upgrade of a large hadoop cluster, since Ambari won't install anything if
> > this check does not pass. May you have any workaround so that the error code
> > returned would be 0?
> 
> See comment #17

the workaround worked. thank you!

Comment 28 Petr Vobornik 2017-03-31 13:51:31 UTC
*** Bug 1435642 has been marked as a duplicate of this bug. ***

Comment 33 alhilaly_a@yahoo.com 2017-06-01 21:47:38 UTC
problem still here!!!
Running transaction check
---> Package ModemManager.i686 0:1.6.0-2.el7 will be installed
--> Processing Dependency: ModemManager-glib(x86-32) = 1.6.0-2.el7 for package: ModemManager-1.6.0-2.el7.i686
--> Processing Dependency: libmbim-glib.so.4 for package: ModemManager-1.6.0-2.el7.i686
--> Processing Dependency: libqmi-glib.so.5 for package: ModemManager-1.6.0-2.el7.i686
---> Package glibc.i686 0:2.17-106.el7_2.8 will be installed
--> Processing Dependency: glibc-common = 2.17-106.el7_2.8 for package: glibc-2.17-106.el7_2.8.i686
--> Finished Dependency Resolution
Error: Package: ModemManager-1.6.0-2.el7.i686 (rhel-7-server-optional-beta-rpms)
           Requires: libmbim-glib.so.4
Error: Package: ModemManager-1.6.0-2.el7.i686 (rhel-7-server-optional-beta-rpms)
           Requires: libqmi-glib.so.5
Error: Package: ModemManager-1.6.0-2.el7.i686 (rhel-7-server-optional-beta-rpms)
           Requires: ModemManager-glib(x86-32) = 1.6.0-2.el7
           Available: ModemManager-glib-1.1.0-6.git20130913.el7.i686 (rhel-7-server-rpms)
               ModemManager-glib(x86-32) = 1.1.0-6.git20130913.el7
           Installing: ModemManager-glib-1.1.0-8.git20130913.el7.i686 (rhel-7-server-rpms)
               ModemManager-glib(x86-32) = 1.1.0-8.git20130913.el7
Error: Package: glibc-2.17-106.el7_2.8.i686 (rhel-7-server-rpms)
           Requires: glibc-common = 2.17-106.el7_2.8
           Installed: glibc-common-2.17-157.el7_3.2.x86_64 (@rhel-7-server-rpms)
               glibc-common = 2.17-157.el7_3.2
           Available: glibc-common-2.17-55.el7.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-55.el7
           Available: glibc-common-2.17-55.el7_0.1.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-55.el7_0.1
           Available: glibc-common-2.17-55.el7_0.3.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-55.el7_0.3
           Available: glibc-common-2.17-55.el7_0.5.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-55.el7_0.5
           Available: glibc-common-2.17-78.el7.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-78.el7
           Available: glibc-common-2.17-105.el7.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-105.el7
           Available: glibc-common-2.17-106.el7_2.1.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-106.el7_2.1
           Available: glibc-common-2.17-106.el7_2.4.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-106.el7_2.4
           Available: glibc-common-2.17-106.el7_2.6.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-106.el7_2.6
           Available: glibc-common-2.17-106.el7_2.8.x86_64 (rhel-7-server-rpms)
               glibc-common = 2.17-106.el7_2.8
 You could try using --skip-broken to work around the problem
** Found 6 pre-existing rpmdb problem(s), 'yum check' output follows:
ipa-client-4.4.0-14.el7_3.7.x86_64 has installed conflicts freeipa-client: ipa-client-4.4.0-14.el7_3.7.x86_64
ipa-client-common-4.4.0-14.el7_3.7.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.4.0-14.el7_3.7.noarch
ipa-common-4.4.0-14.el7_3.7.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-14.el7_3.7.noarch
ipa-python-compat-4.4.0-14.el7_3.7.noarch has installed conflicts freeipa-python-compat: ipa-python-compat-4.4.0-14.el7_3.7.noarch
ipa-server-common-4.4.0-14.el7_3.7.noarch has installed conflicts freeipa-server-common: ipa-server-common-4.4.0-14.el7_3.7.noarch
kmod-redhat-ixgbe-4.4.0_k_rh7.4_z-2.el7_3.x86_64 has installed conflicts ixgbe-kmod: kmod-redhat-ixgbe-4.4.0_k_rh7.4_z-2.el7_3.x86_64

Comment 34 system-messages 2017-07-19 07:22:01 UTC
Today undertook yum update which proceeded to update per ID 16 as follows that included flash install for new system installation.

sudo yum history info 16
Loaded plugins: fastestmirror, langpacks, nvidia, priorities
Transaction ID : 16
Begin time     : Wed Jul 19 15:12:57 2017
Begin rpmdb    : 1774:846f14e9d6a6518f1a660d2b787d099b33842d84
End time       :            15:12:58 2017 (1 seconds)
End rpmdb      : 1775:8183e1bc110251558bd79beff06cad9f36843a6d
User           : robertk <robertk>
Return-Code    : Success
Command Line   : install flash-plugin alsa-plugins-pulseaudio libcurl
Transaction performed with:
    Installed     rpm-4.11.3-21.el7.x86_64                      @anaconda
    Installed     yum-3.4.3-150.el7.centos.noarch               @anaconda
    Installed     yum-metadata-parser-1.1.4-10.el7.x86_64       @anaconda
    Installed     yum-plugin-fastestmirror-1.1.31-40.el7.noarch @anaconda
Packages Altered:
    Install flash-plugin-26.0.0.137-release.x86_64 @adobe-linux-x86_64
Rpmdb Problems:
    conflicts: ipa-client-4.4.0-14.el7.centos.7.x86_64 has installed conflicts freeipa-client:
             : ipa-client-4.4.0-14.el7.centos.7.x86_64
        Installed     ipa-client-4.4.0-14.el7.centos.7.x86_64 @updates
    conflicts: ipa-client-common-4.4.0-14.el7.centos.7.noarch has installed conflicts freeipa-client-common:
             : ipa-client-common-4.4.0-14.el7.centos.7.noarch
        Installed     ipa-client-common-4.4.0-14.el7.centos.7.noarch @updates
    conflicts: ipa-common-4.4.0-14.el7.centos.7.noarch has installed conflicts freeipa-common:
             : ipa-common-4.4.0-14.el7.centos.7.noarch
        Installed     ipa-common-4.4.0-14.el7.centos.7.noarch @updates
history info

$ sudo yum check
Loaded plugins: fastestmirror, langpacks, nvidia, priorities
ipa-client-4.4.0-14.el7.centos.7.x86_64 has installed conflicts freeipa-client: ipa-client-4.4.0-14.el7.centos.7.x86_64
ipa-client-common-4.4.0-14.el7.centos.7.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.4.0-14.el7.centos.7.noarch
ipa-common-4.4.0-14.el7.centos.7.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-14.el7.centos.7.noarch
Error: check all


This appears to be same issue as above.

Repo details.
Use priorities as follows:
# list-yum-priorities
priority = 10 [base]
priority = 10 [base-debuginfo]
priority = 10 [base-source]
priority = 10 [C7.0.1406-base]
priority = 10 [C7.0.1406-centosplus]
priority = 10 [C7.0.1406-extras]
priority = 10 [C7.0.1406-fasttrack]
priority = 10 [C7.0.1406-updates]
priority = 10 [C7.1.1503-base]
priority = 10 [C7.1.1503-centosplus]
priority = 10 [C7.1.1503-extras]
priority = 10 [C7.1.1503-fasttrack]
priority = 10 [C7.1.1503-updates]
priority = 10 [C7.2.1511-base]
priority = 10 [C7.2.1511-centosplus]
priority = 10 [C7.2.1511-extras]
priority = 10 [C7.2.1511-fasttrack]
priority = 10 [C7.2.1511-updates]
priority = 10 [centosplus]
priority = 10 [centosplus-source]
priority = 10 [centos-sclo-rh]
priority = 10 [centos-sclo-rh-debuginfo]
priority = 10 [centos-sclo-rh-source]
priority = 10 [centos-sclo-rh-testing]
priority = 10 [centos-sclo-sclo]
priority = 10 [centos-sclo-sclo-debuginfo]
priority = 10 [centos-sclo-sclo-source]
priority = 10 [centos-sclo-sclo-testing]
priority = 10 [extras]
priority = 10 [extras-source]
priority = 10 [fasttrack]
priority = 10 [updates]
priority = 10 [updates-source]
priority = 10 [virtio-win-stable]
priority = 20 [cr]
priority = 20 [epel]
priority = 20 [epel-debuginfo]
priority = 20 [epel-source]
priority = 20 [virtio-win-latest]
priority = 20 [virtio-win-source]
priority = 25 [nux-dextop]
priority = 30 [gf]
priority = 30  [gf-source]
priority = 50 [epel-testing]
priority = 50 [epel-testing-debuginfo]
priority = 50 [epel-testing-source]
priority = 60 [gf-plus]
priority = 60 [gf-plus-source]
priority = 65 [gf-testing]
priority = 65 [gf-testing-source]
priority = 70 [nux-dextop-testing]
priority = 80 [remi-safe]
priority = 80 [remi-safe-debuginfo]
priority = 91 [elrepo]
priority = 92 [elrepo-extras]
priority = 93 [elrepo-testing]
priority = 94 [elrepo-kernel]
priority = 95 [adobe-linux-x86_64]
priority = 95 [atrpms]
priority = 95 [atrpms-debuginfo]
priority = 95 [atrpms-source]
priority = 95 [google]
priority = 95 [google-chrome]
priority = 95 [google-earth]
priority = 96 [psychotic]
priority = 97 [psychotic-plus]
priority = 98 [ius]
priority = 98 [ius-debuginfo]
priority = 98 [ius-source]
priority = 98 [psychotic-testing]
priority = 98 [remi-php54]
priority = 98 [remi-php70]
priority = 98 [remi-php70-debuginfo]
priority = 98 [remi-php71]
priority = 98 [remi-php71-debuginfo]
priority = 98 [remi-php72]
priority = 98 [remi-php72-debuginfo]
priority = 99 [atrpms-bleeding]
priority = 99 [atrpms-bleeding-debuginfo]
priority = 99 [atrpms-bleeding-source]
priority = 99 [atrpms-testing]
priority = 99 [atrpms-testing-debuginfo]
priority = 99 [atrpms-testing-source]
priority = 99 [ius-archive]
priority = 99 [ius-archive-debuginfo]
priority = 99 [ius-archive-source]
priority = 99 [ius-dev]
priority = 99 [ius-dev-debuginfo]
priority = 99 [ius-dev-source]
priority = 99 [ius-testing]
priority = 99 [ius-testing-debuginfo]
priority = 99 [ius-testing-source]
priority = 99 [remi]
priority = 99 [remi-debuginfo]
priority = 99 [remi-php55]
priority = 99 [remi-php55-debuginfo]
priority = 99 [remi-php56]
priority = 99 [remi-php56-debuginfo]
priority = 99 [remi-php70-test]
priority = 99 [remi-php70-test-debuginfo]
priority = 99 [remi-php71-test]
priority = 99 [remi-php71-test-debuginfo]
priority = 99 [remi-php72-test]
priority = 99 [remi-php72-test-debuginfo]
priority = 99 [remi-test]
priority = 99 [remi-test-debuginfo]

Priorities above 98 are disabled.

# yum repolist enabled
Loaded plugins: fastestmirror, langpacks, nvidia, priorities
Determining fastest mirrors
 * base: mirror.aarnet.edu.au
 * elrepo: mirror.ventraip.net.au
 * epel: ucmirror.canterbury.ac.nz
 * extras: mirror.aarnet.edu.au
 * gf: mirror.ghettoforge.org
 * nux-dextop: mirror.li.nux.ro
 * remi-safe: nl.mirror.babylon.network
 * updates: mirror.optus.net
google-chrome                                                                                                                   3/3
google-earth                                                                                                                    2/2
1159 packages excluded due to repository priority protections
repo id                                repo name                                                                          status
adobe-linux-x86_64                     Adobe Systems Incorporated                                                                  3
atrpms/7/x86_64                        Red Hat Enterprise Linux 7 - x86_64 - ATrpms                                          584+243
base/7/x86_64                          CentOS-7 - Base                                                                         9,363
centos-sclo-rh/x86_64                  CentOS-7 - SCLo rh                                                                      5,886
centos-sclo-sclo/x86_64                CentOS-7 - SCLo sclo                                                                      427
elrepo                                 ELRepo.org Community Enterprise Linux Repository - el7                                 188+10
epel/x86_64                            Extra Packages for Enterprise Linux 7 - x86_64                                     11,638+266
extras/7/x86_64                        CentOS-7 - Extras                                                                         447
gf/x86_64                              Ghettoforge packages that won't overwrite core distro packages.                         33+26
google-chrome/x86_64                   google-chrome                                                                               3
google-earth/x86_64                    google-earth                                                                                2
nux-dextop/x86_64                      Nux.Ro RPMs for general desktop use                                                 1,997+476
remi-safe                              Safe Remi's RPM repository for Enterprise Linux 7 - x86_64                          1,950+143
updates/7/x86_64                       CentOS-7 - Updates                                                                      2,100
virtio-win-stable                      virtio-win builds roughly matching what was shipped in latest RHEL                          4
repolist: 34,625

This issue appears to only occur on recently installed machine 

$ uname -a
Linux saturn 3.10.0-514.26.2.el7.x86_64 #1 SMP Tue Jul 4 15:04:05 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Never noticed before but  my older machine with exact same version but different installation and history showed exact same response on yum check. Appears a repeatable endemic issue?

Comment 35 Michal Domonkos 2017-07-19 10:49:38 UTC
(In reply to system-messages from comment #34)
> Today undertook yum update which proceeded to update per ID 16 as follows
> that included flash install for new system installation.

Hey,

The latest version of yum in centos doesn't include this bug fix.  Actually, the patch has been upstream for some time:

commit 1ff69afbb78e9303a0d9859d941371eaedbb6842
Author: James Antill <james@and.org>
Date:   Mon Sep 22 16:22:42 2014 -0400

    Have "yum check" ignore self conflicts.

We're planning on including it in the next RHEL-7 minor release, so it should eventually land in centos as well.

Hope that helps!

Comment 36 system-messages 2017-07-19 20:54:58 UTC
Hi 
Thanks - was only advising of bugs continuing existance at the Centos level which should reflect the RedHat state.

Comment 37 errata-xmlrpc 2017-08-01 09:07:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2295

Comment 38 Ed Greenberg 2017-09-29 14:41:52 UTC
So for the benefit of simple sysadmins who are reading this bug, the resolution at the operational level is to do 'yum update yum' and then 'yum update'.