Bug 1371657

Summary: haproxy config missing auth statement for redis in ha setup
Product: Red Hat OpenStack Reporter: Alex Krzos <akrzos>
Component: openstack-tripleo-heat-templatesAssignee: Pradeep Kilambi <pkilambi>
Status: CLOSED ERRATA QA Contact: Ofer Blaut <oblaut>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 10.0 (Newton)CC: bperkins, jcoufal, jjoyce, jtaleric, mburns, mcornea, mkrcmari, rhel-osp-director-maint, rohara, yprokule
Target Milestone: rcKeywords: Triaged
Target Release: 10.0 (Newton)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160929150845.4cdc4fc.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-12-14 15:54:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Alex Krzos 2016-08-30 18:01:39 UTC
Description of problem:
Deployed an OSP10 cloud via OSPd10 for testing gnocchi, I found gnocchi unable to connect to redis.  Comparison of the haproxy configuration between another OSP9 cloud and this OSP10 cloud showed that an auth statement is missing in the haproxy configuration for redis.

I added the statement into my three controllers and restart haproxy and was able to connect to redis through haproxy rather than directly to the redis server(s).

The config is missing:
tcp-check send AUTH\ (redis password)\r\n


Version-Release number of selected component (if applicable):
2016-08-29.1

How reproducible:


Steps to Reproduce:
1. Install/setup OSPd10
2. Install/Setup OSP10 overcloud
3. View /etc/haproxy/haproxy.cfg for missing tcp-check send AUTH statement

Actual results:


Expected results:


Additional info:
This prevents gnocchi from starting its storage aggregation worker.

Comment 3 Pradeep Kilambi 2016-09-08 13:03:37 UTC
*** Bug 1374326 has been marked as a duplicate of this bug. ***

Comment 4 Pradeep Kilambi 2016-09-13 21:17:20 UTC
*** Bug 1348303 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2016-12-14 15:54:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html