Bug 1373305

Summary: fflas-ffpack 2.2.2 regresses on aarch64 when building linbox
Product: [Fedora] Fedora Reporter: Peter Robinson <pbrobinson>
Component: fflas-ffpackAssignee: Jerry James <loganjerry>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: loganjerry, paulo.cesar.pereira.de.andrade
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: fflas-ffpack-2.2.2-2.fc25 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-10-28 00:41:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 245418    
Attachments:
Description Flags
Proposed patch to guard x86-specific asm in fflas-ffpack none

Description Peter Robinson 2016-09-05 23:34:39 UTC
recent linbox releases have been failing to build [1] but actually when investigating the failure looked to be something around fflas-ffpack:

                 from test-rank.h:56,
                 from test-rank-Int.C:33:
/usr/include/fflas-ffpack/utils/bit_manipulation.h: In function 'uint64_t divide_128(uint64_t, uint64_t, uint64_t, uint64_t*)':
/usr/include/fflas-ffpack/utils/bit_manipulation.h:114:10: error: impossible constraint in 'asm'
         );
          ^
Makefile:2120: recipe for target 'test-rank-Int.o' failed

So checking the version that was last successful shows it was fflas-ffpack 2.2.1 that last worked. Doing a scratch build of the latest linbox against fflas-ffpack 2.2.1 shows it builds [2] against the older version.

[1] http://arm.koji.fedoraproject.org/koji/packageinfo?packageID=4266
[2] http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=3707507

Comment 1 Jerry James 2016-09-06 02:11:30 UTC
Yes, it looks like upstream inserted some x86-specific assembly into one of the header files.  I'll scout around and see if they did that anywhere else before reporting this upstream and fixing.

Comment 2 Jerry James 2016-09-06 03:00:43 UTC
Created attachment 1198059 [details]
Proposed patch to guard x86-specific asm in fflas-ffpack

Is anybody able to build fflas-ffpack with this patch, and then build linbox on top of that?  I know how to do an aarch64 scratch build of fflas-ffpack, but don't know how to do 2 dependent builds like this.  Thanks.

Comment 3 Peter Robinson 2016-09-12 12:01:34 UTC
> Is anybody able to build fflas-ffpack with this patch, and then build linbox
> on top of that?  I know how to do an aarch64 scratch build of fflas-ffpack,
> but don't know how to do 2 dependent builds like this.  Thanks.

aarch64 builds are now enabled in rawhide/f25 in koji.fedoraproject.org so it's probably easiest to push a build there, newRepo, bump linbox and rebuild.

Comment 4 Fedora Update System 2016-10-24 04:53:00 UTC
Macaulay2-1.6-32.fc25, Singular-3.1.7-9.fc25, eclib-20160720-3.fc25, fflas-ffpack-2.2.2-2.fc25, flint-2.5.2-13.fc25, giac-1.2.2-11.85.fc25, givaro-4.0.2-3.fc25, latte-integrale-1.7.3b-1.fc25, linbox-1.4.2-4.fc25, ntl-10.1.0-1.fc25, sagemath-7.3-6.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5ae0a3b688

Comment 5 Fedora Update System 2016-10-28 00:41:42 UTC
Macaulay2-1.6-32.fc25, Singular-3.1.7-9.fc25, eclib-20160720-3.fc25, fflas-ffpack-2.2.2-2.fc25, flint-2.5.2-13.fc25, giac-1.2.2-11.85.fc25, givaro-4.0.2-3.fc25, latte-integrale-1.7.3b-1.fc25, linbox-1.4.2-4.fc25, ntl-10.1.0-1.fc25, sagemath-7.3-6.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.