Bug 1373549

Summary: [RFE] Gnocchi: allows to modify resource types attributes.
Product: Red Hat OpenStack Reporter: Mehdi ABAAKOUK <mabaakou>
Component: openstack-gnocchiAssignee: Mehdi ABAAKOUK <mabaakou>
Status: CLOSED ERRATA QA Contact: Julien Danjou <jdanjou>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 10.0 (Newton)CC: apevec, fbaudin, jdanjou, jjoyce, jschluet, lhh, pkilambi, sclewis
Target Milestone: rcKeywords: FutureFeature, Triaged
Target Release: 10.0 (Newton)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-gnocchi-3.0.0-1.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-12-14 15:57:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1394650    

Description Mehdi ABAAKOUK 2016-09-06 14:49:32 UTC
At the starting of Gnocchi, we have hardcoded some Ceilometer resource types into Gnocchi.

We should be able to create/change/delete them via rest API, instead of using the hardcoded.

Ceilometer should be able to create/update their needed resource types in Gnocchi.

Gnocchi should drop its hardcoded ceilometer resource types.

Comment 2 Mehdi ABAAKOUK 2016-09-06 14:53:19 UTC
Adding and deleting is possible since Gnocchi 2.1
Changing already created resource types should land for 2.3

Comment 3 Mehdi ABAAKOUK 2016-09-06 14:56:54 UTC
nit: Changing already created resource types should land for 3.0

Comment 5 Mehdi ABAAKOUK 2016-09-21 12:16:43 UTC
This feature have landed upstream and will be shipped in Osp10 Gnocchi version (3.0)

Comment 9 errata-xmlrpc 2016-12-14 15:57:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html