Bug 1374296

Summary: update mariadb to version 10
Product: Red Hat OpenStack Reporter: Mike Burns <mburns>
Component: mariadbAssignee: Damien Ciabrini <dciabrin>
Status: CLOSED ERRATA QA Contact: Udi Shkalim <ushkalim>
Severity: medium Docs Contact:
Priority: high    
Version: 13.0 (Queens)CC: apevec, chjones, dciabrin, fdinitto, jschluet, mbayer, mburns, michele, mkrcmari, oblaut, slinaber, sputhenp, srevivo
Target Milestone: betaKeywords: InstallerIntegration, Rebase, Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: mariadb-10.1.20-2.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:26:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mike Burns 2016-09-08 12:11:34 UTC
Description of problem:
Currently RDO has mariadb-10 compared to OSP with 5.  We should update to 10 at the start of the OSP 11 cycle to flesh out any issues with upgrades, etc.

Note:  mariadb-10 contains mariadb-server-galera natively, so we should carry mariadb-10 in our channel (overriding the RHEL version) and drop mariadb-galera.

Comment 1 Michael Bayer 2016-11-07 20:00:38 UTC
*** Bug 1341968 has been marked as a duplicate of this bug. ***

Comment 2 Michael Bayer 2016-12-02 17:22:25 UTC
trying out the centos package via the centos-openstack-mitaka repo.

Here, mariadb-10.1 supplies the galera integration directly.  However, there is still a mariadb-server-galera package, which contains support scripts:

Installed:
  mariadb-server-galera.x86_64 3:10.1.17-1.el7                                                                                    

Complete!
[root@cent-g3 classic]# rpm -ql mariadb-server-galera
/etc/my.cnf.d/galera.cnf
/etc/sysconfig/clustercheck
/usr/bin/clustercheck
/usr/bin/galera_new_cluster
/usr/bin/galera_recovery
/usr/share/doc/mariadb-server-galera-10.1.17
/usr/share/doc/mariadb-server-galera-10.1.17/README.wsrep
/usr/share/licenses/mariadb-server-galera-10.1.17
/usr/share/licenses/mariadb-server-galera-10.1.17/LICENSE.clustercheck
/usr/share/mariadb/systemd/use_galera_new_cluster.conf
/usr/share/selinux/packages/mariadb/mariadb-server-galera.pp


our current rhos mariadb-galera-server package also delivers most of these files.    The mariadb-server package minus the mariadb-server-galera also includes rudimentary galera configuration in /etc/my.cnf.d/mariadb-server.cnf and can be run as a galera cluster without mariadb-galera-server installed, however mariadb-galera-server is providing the familiar galera.cnf file.  The files in this package do not seem to be part of the mariadb-10.1 source distro.

Comment 3 Michael Bayer 2016-12-02 17:30:02 UTC
nevertheless these packages are all part of the mariadb dist-git so we would still retire our separate mariadb-galera dist-git.

Comment 4 Michael Bayer 2016-12-05 17:02:18 UTC
ive added bz#1401609 to add the dist-git branch.  im not sure who does this part.

Comment 11 Jon Schlueter 2018-01-31 16:13:40 UTC
Looking at http://cbs.centos.org/koji/buildinfo?buildID=20049

Comment 13 Jon Schlueter 2018-01-31 17:12:10 UTC
also need multilib-rpm-config-1-6.el7 as BR from cbs to build mariadb

Comment 15 Jon Schlueter 2018-02-01 17:38:47 UTC
multilib-rpm-config-1-6.el7ost available

Comment 17 Jon Schlueter 2018-02-01 18:05:24 UTC
mariadb-10.1.20-2.el7ost available

Comment 18 Alan Pevec 2018-02-01 22:30:27 UTC
Why not 10.1.30 ?

Comment 19 Damien Ciabrini 2018-02-02 07:52:28 UTC
I started with 10.1.20 because we have it for a couple a month now upstream and we know it's rock solid, whereas 10.1.30 is just in the process of being rolled out in RDO.

Since that's a minor release, we can always bump that version later and the OSP minor update workflow will automatically pick it up.

Comment 25 errata-xmlrpc 2018-06-27 13:26:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086