Bug 1374350

Summary: Collector's traceback: object has no attribute 'sample_listener'
Product: Red Hat OpenStack Reporter: Yurii Prokulevych <yprokule>
Component: openstack-ceilometerAssignee: Mehdi ABAAKOUK <mabaakou>
Status: CLOSED ERRATA QA Contact: Yurii Prokulevych <yprokule>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 10.0 (Newton)CC: jjoyce, jruzicka, pkilambi, srevivo
Target Milestone: rcKeywords: Triaged
Target Release: 10.0 (Newton)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-ceilometer-7.0.0-0.2.0rc2.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-12-14 15:58:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Yurii Prokulevych 2016-09-08 13:25:53 UTC
Description of problem:

Traceback in ceilometer/collector.log:
---------------------------------------
2016-09-08 12:04:47.213 22503 INFO cotyledon [-] Caught SIGTERM signal, graceful exiting of service CollectorService(0) [22503]
2016-09-08 12:04:47.213 22503 ERROR cotyledon [-] Unhandled exception
2016-09-08 12:04:47.213 22503 ERROR cotyledon Traceback (most recent call last):
2016-09-08 12:04:47.213 22503 ERROR cotyledon   File "/usr/lib/python2.7/site-packages/cotyledon/__init__.py", line 62, in _exit_on_exception
2016-09-08 12:04:47.213 22503 ERROR cotyledon     yield
2016-09-08 12:04:47.213 22503 ERROR cotyledon   File "/usr/lib/python2.7/site-packages/cotyledon/__init__.py", line 150, in _clean_exit
2016-09-08 12:04:47.213 22503 ERROR cotyledon     self.terminate()
2016-09-08 12:04:47.213 22503 ERROR cotyledon   File "/usr/lib/python2.7/site-packages/ceilometer/collector.py", line 137, in terminate
2016-09-08 12:04:47.213 22503 ERROR cotyledon     if self.sample_listener:
2016-09-08 12:04:47.213 22503 ERROR cotyledon AttributeError: 'CollectorService' object has no attribute 'sample_listener'


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
python-ceilometerclient-2.5.0-0.20160802190010.cfea4ae.el7ost.noarch
openstack-ceilometer-collector-7.0.0-0.20160823020155.d434126.el7ost.noarch
openstack-ceilometer-polling-7.0.0-0.20160823020155.d434126.el7ost.noarch
openstack-ceilometer-api-7.0.0-0.20160823020155.d434126.el7ost.noarch
openstack-ceilometer-common-7.0.0-0.20160823020155.d434126.el7ost.noarch
openstack-ceilometer-central-7.0.0-0.20160823020155.d434126.el7ost.noarch
puppet-ceilometer-9.1.0-0.20160815154656.0bc5123.el7ost.noarch
python-ceilometer-7.0.0-0.20160823020155.d434126.el7ost.noarch
openstack-ceilometer-compute-7.0.0-0.20160823020155.d434126.el7ost.noarch
openstack-ceilometer-notification-7.0.0-0.20160823020155.d434126.el7ost.noarch

Comment 1 Mehdi ABAAKOUK 2016-09-12 07:31:37 UTC
Next 7.0.0 release (7.0.0.0b4 ?) will have the fix.

Comment 2 Mehdi ABAAKOUK 2016-09-21 15:25:16 UTC
This is part of Ceilometer 7.0.0.0rc1 upstream release

Comment 4 Yurii Prokulevych 2016-10-06 13:56:25 UTC
Verified with next packages:
----------------------------
python-ceilometerclient-2.6.1-1.el7ost.noarch
openstack-ceilometer-polling-7.0.0-0.20160928024313.67bbd3f.el7ost.noarch
openstack-ceilometer-central-7.0.0-0.20160928024313.67bbd3f.el7ost.noarch
openstack-ceilometer-common-7.0.0-0.20160928024313.67bbd3f.el7ost.noarch
openstack-ceilometer-compute-7.0.0-0.20160928024313.67bbd3f.el7ost.noarch
puppet-ceilometer-9.4.0-1.el7ost.noarch
python-ceilometer-7.0.0-0.20160928024313.67bbd3f.el7ost.noarch
openstack-ceilometer-collector-7.0.0-0.20160928024313.67bbd3f.el7ost.noarch
openstack-ceilometer-notification-7.0.0-0.20160928024313.67bbd3f.el7ost.noarch
openstack-ceilometer-api-7.0.0-0.20160928024313.67bbd3f.el7ost.noarch

No traceback in ceilometer/collector.log during service's stop/restart.

Comment 7 errata-xmlrpc 2016-12-14 15:58:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html